Results 1 to 5 of 5

Thread: ansible need python-paramiko?

Hybrid View

  1. #1

    ansible need python-paramiko?

    Hello,

    would like to install ansible with SLES12 SP3. But zypper say that I need package python-paramiko, but this package is not in my Repository. How can I install ansible?

    Code:
    smt1:~ # zypper in ansible
    Dienst 'Advanced_Systems_Management_Module_12_x86_64' wird aktualisiert.
    Dienst 'SUSE_Linux_Enterprise_Server_12_SP3_x86_64' wird aktualisiert.
    Dienst 'SUSE_Package_Hub_12_SP3_x86_64' wird aktualisiert.
    Dienst 'Web_and_Scripting_Module_12_x86_64' wird aktualisiert.
    Metadaten von Repository 'SLE-Module-Adv-Systems-Management12-Updates' abrufen ...........................................................................................................................[fertig]
    Cache fr Repository 'SLE-Module-Adv-Systems-Management12-Updates' erzeugen ..............................................................................................................................[fertig]
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    Paketabhngigkeiten werden aufgelst...
    
    Problem: python-paramiko bentigt von ansible-2.4.1.0-6.1.noarch wird nirgends zur Verfgung gestellt
     Lsung 1: ansible-2.4.1.0-6.1.noarch nicht installieren
     Lsung 2: ansible-2.4.1.0-6.1.noarch durch Ignorieren einiger Abhngigkeiten brechen
    
    Whlen Sie aus den obigen Lsungen mittels Nummer oder brechen Sie (a)b [1/2/a] (a): 
    smt1:~ #

    Thx for help & tipps
    Ronald

  2. Re: ansible need python-paramiko?

    Hi and welcome to the Forum :)
    You would need to ask the package maintainers to build and push to backports...
    https://build.opensuse.org/package/s...ython-paramiko

    For SLE 12 SP3 you could download/install direct from;
    https://download.opensuse.org/reposi...on/SLE_12_SP3/
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. Re: ansible need python-paramiko?

    Hi Ronald!
    Quote Originally Posted by ronaldhafer View Post
    Hello,

    would like to install ansible with SLES12 SP3. But zypper say that I need package python-paramiko, but this package is not in my Repository. How can I install ansible?

    Thx for help & tipps
    Ronald
    The python-paramiko package (and a few other required packages) is provided by the Public Cloud Module. Enable that module and then the required python packages will be installed.

    -Scott

  4. #4

    Re: ansible need python-paramiko?

    Thx malcolmlewis,

    I wanted to add the whole python repository to my local repo-server because I need several packages of it but I will first test Scotts solution and if that worked all is good :-)



    Quote Originally Posted by sbahling View Post
    Hi Ronald!


    The python-paramiko package (and a few other required packages) is provided by the Public Cloud Module. Enable that module and then the required python packages will be installed.

    -Scott

    Oh thx sbahling, I will add the repository to my smt-server with:

    Code:
    SUSEConnect -p sle-module-public-cloud/12/x86_64
    I'll get back to you

    Thx & Regards
    Ronald
    Last edited by ronaldhafer; 23-Jan-2018 at 14:56.

  5. #5

    solved - Re: ansible need python-paramiko?

    All perfect It is quite simple if you know in which repo which packages are included. Big thanks to Scott.

    After adding the sle-module-public-cloud repository I could install ansible with:

    Code:
    zypper in ansible
    the problem is solved

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •