Results 1 to 2 of 2

Thread: xmonad

  1. #1
    cureadvocate NNTP User

    xmonad


    I come here seeking the guidance and sage wisdom of those who have
    traveled this path before.

    I am trying to create an appliance with xmonad configured as the
    default window manager, but have failed miserably multiple times.

    My config:

    -Minimal X
    -add huskell and home:hgraeber:haskell 12.1 repos
    -choose the ghc and xmonad packages
    -add ~/.xinitrc containing "exec xmonad"
    -add default ~/.xmonad/xmonad.hs config file

    The graphical login (with xdm) would keep restarting upon logging in,
    so I changed it to console login. I then tried startx, only to fail
    with a message recommending I chmod 4755 /usr/bin/Xorg and try again. I
    comply, then try startx again.

    It teases as if it's going to work, then kicks me back to the command
    line with the following errors:

    (EE) AIGLX error: dlopen of /usr/lib/dri/swrast_dri.so failed
    (/usr/lib/dri/swrast_dri.so: cannot open shared object file: No such
    file or directory)
    (EE) GLX: could not load software renderer
    (EE) QEMU 0.12.1 QEMU USB Tablet: failed to initialize for relative
    axes.

    I'm new to the whole SUSE/non-Debian world, so I'm hoping there's a
    simple "you are simply missing these packages, young Padawan"-type
    answer.

    Any help will be greatly appreciated.


    --
    cureadvocate
    ------------------------------------------------------------------------
    cureadvocate's Profile: http://forums.opensuse.org/member.php?userid=68378
    View this thread: http://forums.opensuse.org/showthread.php?t=475941


  2. #2
    cureadvocate NNTP User

    Re: xmonad


    cureadvocate;2468230 Wrote:
    > It teases as if it's going to work, then kicks me back to the command
    > line with the following errors:

    (EE) AIGLX error: dlopen of
    > /usr/lib/dri/swrast_dri.so failed (/usr/lib/dri/swrast_dri.so: cannot
    > open shared object file: No such file or directory)
    > (EE) GLX: could not load software renderer
    > (EE) QEMU 0.12.1 QEMU USB Tablet: failed to initialize for relative
    > axes.
    >


    The Mesa package fixes the first two errors--the third doesn't matter,
    as the same error occurs when ~/.xinitrc ends in -exec icewm- and
    launches successfully. Off to #xmonad!


    --
    cureadvocate
    ------------------------------------------------------------------------
    cureadvocate's Profile: http://forums.opensuse.org/member.php?userid=68378
    View this thread: http://forums.opensuse.org/showthread.php?t=475941


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •