Results 1 to 2 of 2

Thread: Can no longer run latest R lang

  1. #1

    Can no longer run latest R lang

    Followed the instructions, from here to install the latest R: https://cran.rstudio.com/bin/linux/suse/

    Basically:

    Code:
    sudo zypper addrepo -f \
         http://download.opensuse.org/repositories/devel:/languages:/R:/patched/SLE_12/ \
         R-base
    sudo zypper in R-base
    Unfortunately, as of today 2/19/2018, this command no longer works. It is looking for a new xdg-utils

    Code:
    Problem: nothing provides xdg-utils needed by R-patched-3.4.3-798.1.x86_64
     Solution 1: do not ask to install a solvable providing R-base
     Solution 2: break R-patched-3.4.3-798.1.x86_64 by ignoring some of its dependencies
    Installing `R-core` is also broken. It is looking for libcairo:

    Code:
    Problem: nothing provides libcairo.so.2()(64bit) needed by R-core-3.4.3-798.1.x86_64
     Solution 1: do not install R-core-3.4.3-798.1.x86_64
     Solution 2: break R-core-3.4.3-798.1.x86_64 by ignoring some of its dependencies

  2. Re: Can no longer run latest R lang

    Hi
    You would need to take it up with the OBS maintainers for R....
    https://build.opensuse.org/project/u...ages:R:patched

    I don't see an R-base being built either?
    https://build.opensuse.org/package/b...ository=SLE_12

    They should be building against SLE 12 Backports as well, this may resolve the issue...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •