H4xorzeel,
As ab threatened, I now have my ear to the rail.

SLES 10, whoa! I haven't seen that in a while and as ab mentioned unless you have Long Term Service Pack Support (LTSS) your supported repos are long expired and inaccessible.

I did some checking and LTSS is no longer available for SLES 10:

Service Pack Release FCS Date General Ends LTSS Ends
SUSE Linux Enterprise Server 10 SP1 18 Jun 2007 30 Nov 2008 Dec 2010
SUSE Linux Enterprise Server 10 SP2 19 May 2008 11 Apr 2010 10 Apr 2013
SUSE Linux Enterprise Server 10 SP3 12 Oct 2009 11 Oct 2011 31 Oct 2014
SUSE Linux Enterprise Server 10 SP4 12 Apr 2011 31 Jul 2013 30 Jul 2016

On to the SSSD, it wasn't available on SLES until 11 SP3, and it didn't include the Active Directory providers (you had to use the LDAP and Kerberos providers).

However, the Active Directory provider was made available on SLES 12.

I'm not sure what the SLES 10 kit you currently have now is doing, but I would suggest upgrading regardless as you have no active support vectors now. If Active Directory integration is a primary driver for the future of these systems I would suggest SLES 12.

-- lawrence