I took the opportunity to reboot our KVM server during the Easter vacation. However, on the restarted server the vm's would not load and gave an error message end of file while reading data: Input/Output error. After a number of attempts, I rebuilt the KVM server and copied working vms back onto the system. I now find that small vm's up to about 15GB work OK, but larger vm's all give the "end of file while reading data : input/Output error". Looking at the build data of libvirt, it seems that there was an update on the 14th of March this year which I would think has caused this problem, as I have tried a number of backup vm's which I know work and all give the same error.

Anyone got any ideas how I can get the system back up and working. I tried a sles11sp3 build, but it did not like the defined xml file for the vms and indicated keyboard error, and also tried sles11sp4 with no updates installed, but the dns server errors without the updates being installed so this was no good either.

Any help or suggestions would be gratefully appreciated.