Results 1 to 3 of 3

Thread: [SUMA3] Docker image inspect not working

Hybrid View

  1. #1
    Join Date
    Jun 2013

    Question [SUMA3] Docker image inspect not working


    I’m playing around with the Docker image functionality of SUSE Manager 3. The built process itself works perfect. What I cannot get to work is the "inspect"-part. According to and the packages python and python-xml have to be installed inside the image to get inspect to work. Well, IMHO my Dockerfile does exactly that. Here it is, very simplistic, just for testing:
    FROM suse/sles12sp3:latest
    ENV TZ='Europe/Berlin'
    ARG repo
    ARG cert
    RUN rm /etc/localtime && ln -s /usr/share/zoneinfo/Europe/Berlin /etc/localtime && \
        echo "$cert" > /etc/pki/trust/anchors/RHN-ORG-TRUSTED-SSL-CERT.pem && \
        update-ca-certificates && \
        echo "$repo" > /etc/zypp/repos.d/susemanager:dockerbuild.repo && \
        zypper --gpg-auto-import-keys --non-interactive install python python-xml && \
        zypper clean && rm -rf /var/cache/zypp* && rm -f /etc/zypp/repos.d/susemanager:dockerbuild.repo
    Running the container and executing "rpm –q python python-xml" returns both packages as installed.

    Nevertheless, all I get is this grey question mark in the Updates column after a successful image built. Looking into the details of the image SUSE Manager shows me "Inspect is successful" as Inspect Status. Clicking on "Inspect is successful" gets me "Module function dockerng.sls_build executed (code 2)".

    Except "code 2" everything looks fine for me.

    We are running version 3.1.5 of SUSE Manager. Someone got a hint were to start trouble-shooting?

    Thanks and best regards

  2. Re: [SUMA3] Docker image inspect not working

    /var/log/rhn/rhn_web_ui.log and /var/log/salt/master (both on SUSE Manager server) should be the first candidates to check. Otherwise, please open a support request.

  3. #3
    Join Date
    Jun 2013

    [SOLVED] [SUMA3] Docker image inspect not working

    The last SUSE Manager updates to 3.1.6 solved this issue.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts