On 22/06/18 17:14, tissupport wrote:

> SLES 11 SP4 provides
>
> mysql server and libmysqlclient in version 5.5.43.
> It also provides libmysqlclient in version 5.0.96.
>
> But the SDK only provides a devel rpm for libmysqlclient 5.0.96.
>
> Is the devel rpm for 5.5.43 missing or can I use the 5.0.96 devel also
> if building a client
> based on libmysqlclient 5.5.43 ?


For libmysqlclient for MySQL 5.5.43 you need to install
libmysql55client_r18-32bit-5.5.43-0.7.3.x86_64.rpm

This would also suggest that your server is not fully patched as the
latest libmysql55client (to match latest MySQL available for SLES11 SP4)
is 5.5.60.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------