Results 1 to 3 of 3

Thread: Autoyast.xml needed for an auto install for Novell OES 11

  1. #1

    Autoyast.xml needed for an auto install for Novell OES 11

    Here you have an example xml file , but it not works. I want to install novell oes 11 with an autoyast file, can you give me some suggestions? Thanks.
    Code:
    <?xml version="1.0"?>
    <profile xmlns="http://www.suse.com/1.0/yast2ns" xmlns:config="http://www.suse.com/1.0/configns">
    <add-on>
        <add_on_products config:type="list">
          <listentry>
            <media_url>nfs://192.168.181.131/media/opsware/linux/OES11/</media_url>
            <product>OPEN_ENTERPRISE_SERVER</product>
            <product_dir>/</product_dir>
          </listentry>
        </add_on_products>
      </add-on>
      <configure>
        <scripts>
          <post-scripts config:type="list"/>
          <pre-scripts config:type="list"/>
        </scripts>
        <users config:type="list">
          <user>
            <encrypted config:type="boolean">false</encrypted>
            <user_password>opsware</user_password>
            <username>root</username>
          </user>
          <user>
            <encrypted config:type="boolean">false</encrypted>
            <user_password>opsware</user_password>
            <username>shadow</username>
          </user>
        </users>
        <networking>
          <dns>
            <dhcp_hostname config:type="boolean">true</dhcp_hostname>
            <dhcp_resolv config:type="boolean">true</dhcp_resolv>
          </dns>
          <interfaces config:type="list">
            <interface>
              <bootproto>dhcp</bootproto>
              <device>eth0</device>
              <startmode>onboot</startmode>
            </interface>
          </interfaces>
        </networking>
      </configure>
      <install>
        <bootloader>
          <activate config:type="boolean">false</activate>
          <kernel_parameters></kernel_parameters>
          <lba_support config:type="boolean">false</lba_support>
          <linear config:type="boolean">false</linear>
          <location>mbr</location>
        </bootloader>
        <firewall>
          <FW_ALLOW_FW_BROADCAST_DMZ>no</FW_ALLOW_FW_BROADCAST_DMZ>
          <FW_ALLOW_FW_BROADCAST_EXT>no</FW_ALLOW_FW_BROADCAST_EXT>
          <FW_ALLOW_FW_BROADCAST_INT>no</FW_ALLOW_FW_BROADCAST_INT>
          <FW_DEV_DMZ></FW_DEV_DMZ>
          <FW_DEV_EXT>eth0</FW_DEV_EXT>
          <FW_DEV_INT></FW_DEV_INT>
          <FW_FORWARD_ALWAYS_INOUT_DEV></FW_FORWARD_ALWAYS_INOUT_DEV>
          <FW_FORWARD_MASQ></FW_FORWARD_MASQ>
          <FW_IGNORE_FW_BROADCAST_DMZ>no</FW_IGNORE_FW_BROADCAST_DMZ>
          <FW_IGNORE_FW_BROADCAST_EXT>yes</FW_IGNORE_FW_BROADCAST_EXT>
          <FW_IGNORE_FW_BROADCAST_INT>no</FW_IGNORE_FW_BROADCAST_INT>
          <FW_IPSEC_TRUST>no</FW_IPSEC_TRUST>
          <FW_LOG_ACCEPT_ALL>no</FW_LOG_ACCEPT_ALL>
          <FW_LOG_ACCEPT_CRIT>yes</FW_LOG_ACCEPT_CRIT>
          <FW_LOG_DROP_ALL>no</FW_LOG_DROP_ALL>
          <FW_LOG_DROP_CRIT>yes</FW_LOG_DROP_CRIT>
          <FW_MASQUERADE>no</FW_MASQUERADE>
          <FW_PROTECT_FROM_INT>no</FW_PROTECT_FROM_INT>
          <FW_ROUTE>no</FW_ROUTE>
          <FW_SERVICES_DMZ_IP></FW_SERVICES_DMZ_IP>
          <FW_SERVICES_DMZ_RPC></FW_SERVICES_DMZ_RPC>
          <FW_SERVICES_DMZ_TCP></FW_SERVICES_DMZ_TCP>
          <FW_SERVICES_DMZ_UDP></FW_SERVICES_DMZ_UDP>
          <FW_SERVICES_EXT_IP></FW_SERVICES_EXT_IP>
          <FW_SERVICES_EXT_RPC></FW_SERVICES_EXT_RPC>
          <FW_SERVICES_EXT_TCP></FW_SERVICES_EXT_TCP>
          <FW_SERVICES_EXT_UDP></FW_SERVICES_EXT_UDP>
          <FW_SERVICES_INT_IP></FW_SERVICES_INT_IP>
          <FW_SERVICES_INT_RPC></FW_SERVICES_INT_RPC>
          <FW_SERVICES_INT_TCP></FW_SERVICES_INT_TCP>
          <FW_SERVICES_INT_UDP></FW_SERVICES_INT_UDP>
          <enable_firewall config:type="boolean">false</enable_firewall>
          <start_firewall config:type="boolean">false</start_firewall>
        </firewall>
        <report>
            <messages>
              <timeout config:type="integer">10</timeout>
            </messages>
          <errors>
              <timeout config:type="integer">10</timeout>
            </errors>
          <warnings>
              <timeout config:type="integer">10</timeout>
            </warnings>
        </report>
        <runlevel>
          <default>3</default>
        </runlevel>
        <general>
          <clock>
            <hwclock>GMT</hwclock>
            <timezone>US/Pacific</timezone>
          </clock>
          <keyboard>
            <keymap>english-us</keymap>
          </keyboard>
          <language>en_US</language>
          <mode>
            <confirm config:type="boolean">false</confirm>
            <reboot config:type="boolean">true</reboot>
            <interactive config:type="boolean">false</interactive>
          </mode>
          <signature-handling>
            <accept_unsigned_file         config:type="boolean">true</accept_unsigned_file>
            <accept_file_without_checksum config:type="boolean">true</accept_file_without_checksum>
            <accept_verification_failed   config:type="boolean">true</accept_verification_failed>
            <accept_unknown_gpg_key       config:type="boolean">true</accept_unknown_gpg_key>
            <import_gpg_key               config:type="boolean">true</import_gpg_key>
            <accept_non_trusted_gpg_key   config:type="boolean">true</accept_non_trusted_gpg_key>
          </signature-handling>
          <mouse>
            <id>20_imps2</id>
          </mouse>
        </general>
        <partitioning config:type="list">
        <drive>
          <device>/dev/sda</device>
          <use>all</use>
          <partitions config:type="list">
            <partition>
    		<filesystem config:type="symbol">reiser</filesystem>
    	  <mount>/boot</mount>
    	  <size>100mb</size>
    	</partition>
    	<partition>
    	  <mount>swap</mount>
    	  <size>1gb</size>
    	</partition>
    	<partition>
    	<filesystem config:type="symbol">reiser</filesystem>
      	  <mount>/</mount>
    	  <size>max</size>
            </partition>
          </partitions>
        </drive>
        </partitioning>
        <software>
          <patterns config:type="list">
            <pattern>base</pattern>
    		<pattern>32bit</pattern>
          	<pattern>base-32bit</pattern>
    		<pattern>apparmor</pattern>
          </patterns>
        </software>
      </install>
    </profile>

  2. #2

    Re: Autoyast.xml needed for an auto install for Novell OES

    Here is the error message that i get when trying to autoinstall this OS :

    Code:
    Calling the YaST module 'inst_oes_preconfig has failed. More information can be found near the end of the '/var/log/YaST2/y2log' file


    The logfile says the following :

    Code:
    Can't find YCP client component inst_oes_preconfig : No such file or directory

  3. #3

    Re: Autoyast.xml needed for an auto install for Novell OES

    Ok, found the solution. If anybody encounters this problem, just add the following rpm into the rpm section of the XML:

    <software>
    <packages config:type="list">
    <package>yast2-novell-commonn</package>

    If anybody needs this specific xml, don't hesitate to email me.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •