Results 1 to 2 of 2

Thread: First Boot - Network setup

Threaded View

  1. #1

    First Boot - Network setup

    Hi,

    Problem Statement : Unable to setup network during first-boot while setting up SLES-12-SP3.

    Default Network Manager In use : Network/Wicked

    Background:
    We have created a virtual appliance (OVF format) using KIWI tool based on SLES-12-SP3. Following is the default first boot configuration.

    HTML Code:
    <?xml version="1.0"?>
    <productDefines  xmlns="http://www.suse.com/1.0/yast2ns" xmlns:config="http://www.suse.com/1.0/configns">
    
        <textdomain>firstboot</textdomain>
    
        <globals>
    
            <!-- The default value of "Automatic Login" checkbox -->
            <enable_autologin config:type="boolean">false</enable_autologin>
            
            <automatic_configuration config:type="list">
                <!--
                Configure printer (needs configured network for net-detection)
                -->
                <ac_step>
                    <text_id>ac_label_2</text_id>
                    <icon>yast-hwinfo</icon>
                    <type>proposals</type>
                    <ac_items config:type="list">
                        <ac_item>printer</ac_item>
                    </ac_items>
                </ac_step>
            </automatic_configuration>
        </globals>
        <proposals config:type="list">
            <proposal>
                <name>firstboot_hardware</name>
                <mode>installation</mode>
                <stage>firstboot</stage>
                <label>Hardware Configuration</label>
                <proposal_modules config:type="list">
                    <proposal_module>printer</proposal_module>
                </proposal_modules>
            </proposal>
        </proposals>
        <workflows  config:type="list">
            <workflow>
                <defaults>
                    <enable_back>yes</enable_back>
                    <enable_next>yes</enable_next>
                    <archs>all</archs>
                </defaults>
                <stage>firstboot</stage>
                <label>Configuration</label>
                <mode>installation</mode>
                <modules  config:type="list">
                    <module>
                        <label>Network Autosetup</label>
                        <name>firstboot_setup_dhcp</name>
                    </module>
                    <module>
                        <label>Keyboard Layout</label>
                        <enabled config:type="boolean">false</enabled>
                        <name>firstboot_keyboard</name>
                    </module>
                    <module>
                        <label>Welcome</label>
                        <name>firstboot_welcome</name>
                    </module>
                    <module>
                        <label>License Agreement</label>
                        <enabled config:type="boolean">true</enabled>
                        <name>firstboot_license_novell</name>
                    </module>
                    <module>
                        <label>Host Name</label>
                        <enabled config:type="boolean">true</enabled>
                        <name>firstboot_hostname</name>
                    </module>
                    <module>
                        <label>Network</label>
                        <!-- this step only restarts service 'network' -->
                        <name>firstboot_network_write</name>
                        <enabled config:type="boolean">true</enabled>
                    </module>
                    <module>
                        <enabled config:type="boolean">true</enabled>
                        <name>firstboot_ssh</name>
                    </module>
                    <module>
                        <label>Network</label>
                        <name>inst_lan</name>
                        <enabled config:type="boolean">true</enabled>
                    </module>
                     <module>
                        <label>Automatic Configuration</label>
                        <name>inst_automatic_configuration</name>
                        <enabled config:type="boolean">false</enabled>
                     </module>
                    <module>
                        <label>Time and Date</label>
                        <enabled config:type="boolean">true</enabled>
                        <name>firstboot_timezone</name>
                    </module>
                    <module>
                        <label>NTP Client</label>
                        <enabled config:type="boolean">false</enabled>
                        <name>firstboot_ntp</name>
                    </module>
                    <module>
                        <label>Desktop</label>
                        <enabled config:type="boolean">false</enabled>
                        <name>firstboot_desktop</name>
                    </module>
                    <module>
                        <label>Network</label>
                        <name>inst_lan</name>
                        <enabled config:type="boolean">true</enabled>
                    </module>
                    <module>
                        <label>Root Password</label>
                        <enabled config:type="boolean">true</enabled>
                        <name>firstboot_root</name>
                    </module>
                    <module>
                        <label>Hardware</label>
                        <name>inst_proposal</name>
                        <enabled config:type="boolean">false</enabled>
                        <proposal>firstboot_hardware</proposal>
                    </module>
                    <module>
                        <label>Finish Setup</label>
                        <name>firstboot_write</name>
                        <enable_back>no</enable_back>
                        <enable_next>no</enable_next>
                    </module>
                    <module>
                        <label>Finish Setup</label>
                        <name>inst_congratulate</name>
                    </module>
    
                </modules>
            </workflow>
        </workflows>
        <texts>
            <!--
            Labels used during Automatic Configuration: use "text_id" from "ac_step"
            -->
            <ac_label_1><label>Configuring network...</label></ac_label_1>
            <ac_label_2><label>Configuring hardware...</label></ac_label_2>
        </texts>
    </productDefines>
    So, as part of the configured first-boot workflow, we are able to navigate across all the modules/screens. But the network setup screen doesn't show up.

    However after first-boot, by logging into the VM, and re-opening the Yast, we are able to navigate and setup the network.

    So our doubt is why we are not able to setup the Network during the First-boot despite the network module is enabled in the first-boot workflow.

    Regards,
    Naresh.
    Last edited by ankuskani82; 18-Jul-2018 at 12:39.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •