Results 1 to 5 of 5

Thread: Ethernet problem using Intel PRO/1000 GT Desktop Adapter

Hybrid View

  1. #1

    Question Ethernet problem using Intel PRO/1000 GT Desktop Adapter

    Hello everyone,

    Last week I started last to use SUSE 11 installed on a PC used for an old project.
    I have a problem with the network card (Intel PRO/1000 GT Desktop Adapter).
    Connecting the ethernet cable to a Beckhoff module (EK1100), the light on the PC-Port lights up, while nothing happens on the module.
    This happens even if connected to a switch instead of the Beckhoff module.
    The Beckhoff module has been tested with an another PC and it works.

    I have already done several tests, but without positive results:

    • changed the cable
    • changed network card slot in the PCI
    • reinstalled the network card driver (e1000)




    Someone with more experience knows by chance what could be the problem?

    Thanks to anyone who decides to help me!

  2. Re: Ethernet problem using Intel PRO/1000 GT Desktop Adapter

    Quote Originally Posted by jam_hir0 View Post
    Hello everyone,

    Last week I started last to use SUSE 11 installed on a PC used for an old project.
    I have a problem with the network card (Intel PRO/1000 GT Desktop Adapter).
    Connecting the ethernet cable to a Beckhoff module (EK1100), the light on the PC-Port lights up, while nothing happens on the module.
    This happens even if connected to a switch instead of the Beckhoff module.
    The Beckhoff module has been tested with an another PC and it works.

    I have already done several tests, but without positive results:

    • changed the cable
    • changed network card slot in the PCI
    • reinstalled the network card driver (e1000)




    Someone with more experience knows by chance what could be the problem?

    Thanks to anyone who decides to help me!
    Hi and welcome to the Forum
    AFAIK you need a patched kernel module for ethercat devices, so the PC you tested on and it worked has what operating system and kernel module (version).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Re: Ethernet problem using Intel PRO/1000 GT Desktop Adapter

    jam hir0 wrote:

    >
    > Hello everyone,
    >
    > Last week I started last to use SUSE 11 installed on a PC used for an
    > old project.
    > I have a problem with the network card (Intel PRO/1000 GT Desktop
    > Adapter).
    > Connecting the ethernet cable to a Beckhoff module (EK1100), the light
    > on the PC-Port lights up, while nothing happens on the module.
    > This happens even if connected to a switch instead of the Beckhoff
    > module.
    > The Beckhoff module has been tested with an another PC and it works.
    >
    > I have already done several tests, but without positive results:
    >
    >
    > - changed the cable
    > - changed network card slot in the PCI
    > - reinstalled the network card driver (e1000)
    >
    >
    >
    >
    > Someone with more experience knows by chance what could be the
    > problem?
    >
    > Thanks to anyone who decides to help me!


    Hello Jam_hir0,

    Welcome to the SUSE forums.

    When the light on the Ethernet adapter lights up it is telling you that
    you have a good connection to a device at the other end but to
    communicate with the device you need more.

    I think this is the device to which you are referring:
    https://www.beckhoff.com/english.asp...cat/ek1100.htm

    It is very likely that you need a special driver to make this work and
    that driver has to be compatible with the specific version of your SLES
    system.

    I would suggest you contact Beckhoff to find out what drivers you might
    need:

    > Beckhoff offers you comprehensive technical assistance, helping you
    > not only with the application of individual Beckhoff products, but
    > also with wide-ranging services


    In the mean time, should anyone reading your post be familiar with this
    piece of hardware, please provide additional about your system.

    To begin, please paste the output from this command when replying to my
    post:
    cat /etc/*release


    --
    Kevin Boyle - Knowledge Partner
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below this post.
    Thank you.

  4. #4

    Arrow Re: Ethernet problem using Intel PRO/1000 GT Desktop Adapter

    Firstly, thank you for the help!

    I will try also to write directly to Beckhoff.


    Quote Originally Posted by KBOYLE View Post

    To begin, please paste the output from this command when replying to my
    post:
    cat /etc/*release
    Code:
    openSUSE 11.0 (i586)
    VERSION =11.0

  5. #5

    Re: Ethernet problem using Intel PRO/1000 GT Desktop Adapter

    jam hir0 Wrote in message:

    > Firstly, thank you for the help!
    >
    > I will try also to write directly to Beckhoff.
    >
    >
    > KBOYLE;54031 Wrote:
    >>
    >>
    >> To begin, please paste the output from this command when replying to my
    >> post:
    >> cat /etc/*release
    >>
    >>

    >
    >
    > Code:
    > --------------------
    >
    > openSUSE 11.0 (i586)
    > VERSION =11.0
    >
    > --------------------


    These forums are for SUSE Linux Enterprise Server (SLES) whereas
    you are using the community supported openSUSE Linux so you
    should repost your issue in the openSUSE Forums at
    https://forums.opensuse.org/forum.php

    However I will note that openSUSE Linux is quite old now so the
    first thing you should try is upgrading to a more recent release
    or at least trying a test install on the same hardware to see
    whether your issue has been resolved.

    HTH.
    --
    Simon Flood
    SUSE Knowledge Partner


    ----Android NewsGroup Reader----
    http://usenet.sinaapp.com/

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •