Hello everyone,

First let me preface by saying, I know this is very old, and if I did not need the server to continue, I would scrap it and install a fresh new OS. However, that being the case, I am stuck with it for now.

I have everyone working like I would expect, except NFS. For some reason when I use the mount -t nfs server:/share/123 /mnt/share it gives me an error:

mount server reported tcp not available, falling back to udp
mount: RPC: Program not registered

I have other linux servers that can access it just fine. Here is the weird part...it was working before. We needed to reboot the server, and when we did, it just stopped working. /etc/fstab has not changed, but for some reason it will not mount the NFS share any longer.

Things I have tried:

stoping/restarting/rebooting portmap, nfs, nfsboot, nfslock
Messing about with the firewall - currently shut off
creating new local folders to try and mount it there
checked and rechecked /etc/exports on the nfs server
tried mounting via IP rather than name
checked /etc/hosts.allow /hosts.deny
Verified that the NFS server is hosting NFS 4,3,2

I am able to ping by name and IP. I can SSH and SCP.

Is there something I am missing? Normally setting up NFS is super fast and easy...

Appreciate any help you can give.

All the best,