Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Low screen resolution

  1. Low screen resolution

    Hi guys!

    I've just installed SLES for SAP 12 SP3 and I only have available 640x480 screen resolution on my machine, so it's being too difficult to peform some GUI tasks.

    On the same machine, it doesn't happen with SLES 11 SP3.

    This is the output of "/sbin/lspci -nnk |grep -A2 VGA" command:

    06:00.0 VGA compatible controller [0300]: Silicon Motion, Inc. SM750 [126f:0750] (rev a1)
    Subsystem: Silicon Motion, Inc. SM750 [126f:0750]
    7f:08.0 System peripheral [0880]: Intel Corporation Xeon E7 v2/Xeon E5 v2/Core i 7 QPI Link 0 [8086:0e80] (rev 07)
    server:/etc/X11/xorg.conf.d # /sbin/lspci -nnk |grep -A2 VGA
    06:00.0 VGA compatible controller [0300]: Silicon Motion, Inc. SM750 [126f:0750] (rev a1)
    Subsystem: Silicon Motion, Inc. SM750 [126f:0750]
    7f:08.0 System peripheral [0880]: Intel Corporation Xeon E7 v2/Xeon E5 v2/Core i7 QPI Link 0 [8086:0e80] (rev 07)


    Could you help me?

    Thank you and best regards.
    Last edited by kgroneman; 22-Oct-2018 at 16:08. Reason: At OP request

  2. Re: Low screen resolution

    Hi and welcome to the Forum
    Can you post the output from the command;
    Code:
    cat /etc/default/grub
    Above to see the boot options (in case nomodeset is added).

    So your booting to a desktop environment? If so, open a terminal and run the command;
    Code:
    xrandr
    Can you also post the output from (a little different than your original);
    Code:
    /sbin/lspci -nnk |egrep -A3 "VGA|Display|3D"
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. Re: Low screen resolution

    Hi malcolmlewis.

    Thanks for your fast response.

    Here you are the output of the commands:

    Code:
    # cat /etc/default/grub
    # If you change this file, run 'grub2-mkconfig -o /boot/grub2/grub.cfg' afterwards to update
    # /boot/grub2/grub.cfg.
    
    # Uncomment to set your own custom distributor. If you leave it unset or empty, the default
    # policy is to determine the value from /etc/os-release
    GRUB_DISTRIBUTOR=
    GRUB_DEFAULT=saved
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=8
    GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/system/swap quiet showopts intel_idle.max_cstate=1 processor.max_cstate=1"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to automatically save last booted menu entry in GRUB2 environment
    
    # variable `saved_entry'
    # GRUB_SAVEDEFAULT="true"
    #Uncomment to enable BadRAM filtering, modify to suit your needs
    
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    # GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    #Uncomment to disable graphical terminal (grub-pc only)
    
    GRUB_TERMINAL="gfxterm"
    # The resolution used on graphical terminal
    #note that you can use only modes which your graphic card supports via VBE
    
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE="auto"
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    # GRUB_DISABLE_LINUX_UUID=true
    #Uncomment to disable generation of recovery mode menu entries
    
    # GRUB_DISABLE_LINUX_RECOVERY="true"
    #Uncomment to get a beep at grub start
    
    # GRUB_INIT_TUNE="480 440 1"
    GRUB_BACKGROUND=/boot/grub2/themes/SLE/background.png
    GRUB_THEME=/boot/grub2/themes/SLE/theme.txt
    SUSE_BTRFS_SNAPSHOT_BOOTING="true"
    GRUB_DISABLE_OS_PROBER="true"
    GRUB_ENABLE_CRYPTODISK="n"
    GRUB_CMDLINE_XEN_DEFAULT="vga=gfx-1024x768x16"

    Code:
    # xrandr
    
    Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
    default connected primary 640x480+0+0 0mm x 0mm
       640x480       73.00*

    Code:
    # /sbin/lspci -nnk |egrep -A3 "VGA|Display|3D"
    06:00.0 VGA compatible controller [0300]: Silicon Motion, Inc. SM750 [126f:0750] (rev a1)
            Subsystem: Silicon Motion, Inc. SM750 [126f:0750]
    7f:08.0 System peripheral [0880]: Intel Corporation Xeon E7 v2/Xeon E5 v2/Core i7 QPI Link 0 [8086:0e80] (rev 07)
            Subsystem: Intel Corporation Xeon E7 v2/Xeon E5 v2/Core i7 QPI Link 0 [8086:0e80]
    Thank you!

  4. Re: Low screen resolution

    Hi
    OK, so did you add these options to grub?
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="....... intel_idle.max_cstate=1 processor.max_cstate=1"
    
    GRUB_CMDLINE_XEN_DEFAULT="vga=gfx-1024x768x16"
    So it's not finding the graphics driver in your lspci output (not sure why...)

    Can you upload the /var/log/xorg.log.0 to say https://susepaste.org/


    It looks like the video card isn't supported....
    Code:
    zcat /proc/config.gz > config.txt
    
    cat config.txt | grep FB_SM7
    
    # CONFIG_FB_SM712 is not set
    # CONFIG_FB_SM750 is not set
    Lets see what the xorg log says... can you add a video card and disable the other?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. Re: Low screen resolution

    On Thu 11 Oct 2018 02:54:02 PM CDT, malcolmlewis wrote:


    Hi
    OK, so did you add these options to grub?

    Code:
    --------------------

    GRUB_CMDLINE_LINUX_DEFAULT="....... intel_idle.max_cstate=1
    processor.max_cstate=1"
    GRUB_CMDLINE_XEN_DEFAULT="vga=gfx-1024x768x16"

    --------------------


    So it's not finding the graphics driver in your lspci output (not sure
    why...)

    Can you upload the /var/log/xorg.log.0 to say https://susepaste.org/


    It looks like the video card isn't supported....

    Code:
    --------------------

    zcat /proc/config.gz > config.txt

    cat config.txt | grep FB_SM7

    # CONFIG_FB_SM712 is not set
    # CONFIG_FB_SM750 is not set

    --------------------


    Lets see what the xorg log says... can you add a video card and disable
    the other?


    Hi
    Also can you post the output from;

    Code:
    uname -a
    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.19-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  6. Re: Low screen resolution

    Hi.

    I've added this one to grub (it's a SAP recommendation):

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="....... intel_idle.max_cstate=1 processor.max_cstate=1"
    But not this one:

    Code:
    GRUB_CMDLINE_XEN_DEFAULT="vga=gfx-1024x768x16"
    I've uploaded the "/var/log/Xorg.0.log" logfile to: https://susepaste.org/79000189

    About the not-supported videocard: It was working on SUSE 12 SP3. I can't undestand why it doesn't work now.

    Also, here is the output of uname -a:
    Code:
    # uname -a
    Linux server 4.4.156-94.57-default #1 SMP Tue Oct 2 06:43:37 UTC 2018 (82521a6) x86_64 x86_64 x86_64 GNU/Linux
    Thank you and best regards
    Last edited by kgroneman; 22-Oct-2018 at 16:11. Reason: at OP request

  7. Re: Low screen resolution

    Quote Originally Posted by soportei3s View Post
    Hi.

    I've added this one to grub (it's a SAP recommendation):

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="....... intel_idle.max_cstate=1 processor.max_cstate=1"
    But not this one:

    Code:
    GRUB_CMDLINE_XEN_DEFAULT="vga=gfx-1024x768x16"
    I've uploaded the "/var/log/Xorg.0.log" logfile to: https://susepaste.org/79000189

    About the not-supported videocard: It was working on SUSE 12 SP3. I can't undestand why it doesn't work now.

    Also, here is the output of uname -a:
    Code:
    # uname -a
    Linux server 4.4.156-94.57-default #1 SMP Tue Oct 2 06:43:37 UTC 2018 (82521a6) x86_64 x86_64 x86_64 GNU/Linux
    Thank you and best regards
    Hi
    I think you meant SLES 11 SP3? It's in the staging sm750fb for 12 SP3, so not technically in the kernel.

    So it's only using the vesa driver by the looks, can you add an additional grub kernel option (same place as the cstate ones);
    Code:
    video=1024x768
    See if that helps, if not I do have the sm750 driver built as an rpm (unsupported) but needs some additional step to install....
    Last edited by kgroneman; 22-Oct-2018 at 16:11.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. Re: Low screen resolution

    Hi.

    Still not work :-(

    Any suggestion?

    Thank you!

  9. Re: Low screen resolution

    On Mon 15 Oct 2018 01:44:01 PM CDT, soportei3s wrote:


    Hi.

    Still not work :-(

    Any suggestion?

    Thank you!


    Hi
    OK, remove that grub option...

    Can you try setting the resolution via xrandr as your user once logged
    in, open a terminal and run;
    Code:
    xrandr -s 1024x768
    Else, if you want to try the driver it needs rebuilding on your
    system;

    Download the src rpm from here;
    Code:
    https://download.opensuse.org/repositories/home:/malcolmlewis:/SLE_12_General/SLE_12_SP3/src/sm750-4.4.73-3.1.src.rpm
    It can be rebuilt as your user and only the kmp rpm needs installing as
    root user, so as root user install;
    Code:
    zypper ref
    zypper up
    zypper in kernel-source kernel-syms libelf-devel module-init-tools make gcc rpmbuild
    Now as your user rebuild the src rpm to match your kernel;
    Code:
    rpmbuild --rebuild sm750-4.4.73-3.1.src.rpm
    It will create a directory called rpmbuild and build the kmp rpm, you
    will see the location of the rpm in the final output which is what
    needs installing as root user;
    Code:
    zypper in /home/<username>/rpmbuild/RPMS/x86_64/sm750-kmp*
    Reboot and see how that goes.

    Project Ref: https://build.opensuse.org/package/s..._General/sm750

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.19-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  10. Re: Low screen resolution

    Hi.

    the execution of xrand -s:

    Code:
    # xrand -s 1024x768
    Size 1024x768 not found in available modes
    And the result of the other commands :

    Code:
    server:~ # zypper ref
    Repository 'SLE-12-SP3-SAP-Updates' is up to date.
    Repository 'SLE-HA12-SP3-Pool' is up to date.
    Repository 'SLE-HA12-SP3-Updates' is up to date.
    Repository 'SLE12-SP3-SAP-Pool' is up to date.
    Repository 'SLES12-SP3-Pool' is up to date.
    Retrieving repository 'SLES12-SP3-Updates' metadata ........................................................................[done]
    Building repository 'SLES12-SP3-Updates' cache .............................................................................[done]
    All repositories have been refreshed.
    server:~ # zypper up
    Refreshing service 'SUSE_Linux_Enterprise_Server_for_SAP_Applications_12_SP3_x86_64'.
    Loading repository data...
    Reading installed packages...
    
    The following 4 NEW packages are going to be installed:
      kernel-default-4.4.156-94.61.1 kernel-default-devel-4.4.156-94.61.1 kernel-devel-4.4.156-94.61.1 kernel-source-4.4.156-94.61.1
    
    The following 51 packages are going to be upgraded:
      bash bash-doc kernel-macros libMagickCore-6_Q16-1 libMagickWand-6_Q16-1 libX11-6 libX11-6-32bit libX11-data libX11-xcb1
      libX11-xcb1-32bit libatomic1 libatomic1-32bit libgcc_s1 libgcc_s1-32bit libgomp1 libgomp1-32bit libitm1 libitm1-32bit
      libreadline6 libstdc++6 libstdc++6-32bit libtsan0 libwacom-data libwacom2 libxcb-dri2-0 libxcb-dri2-0-32bit libxcb-dri3-0
      libxcb-dri3-0-32bit libxcb-glx0 libxcb-glx0-32bit libxcb-present0 libxcb-present0-32bit libxcb-randr0 libxcb-render0
      libxcb-render0-32bit libxcb-shape0 libxcb-shm0 libxcb-shm0-32bit libxcb-sync1 libxcb-sync1-32bit libxcb-xf86dri0 libxcb-xfixes0
      libxcb-xfixes0-32bit libxcb-xinerama0 libxcb-xkb1 libxcb-xv0 libxcb1 libxcb1-32bit readline-doc xorg-x11-server
      xorg-x11-server-extra
    
    51 packages to upgrade, 4 new.
    Overall download size: 2.8 MiB. Already cached: 156.7 MiB. After the operation, additional 772.0 MiB will be used.
    Continue? [y/n/...? shows all options] (y): y
    In cache kernel-macros-4.4.156-94.61.1.noarch.rpm                                           (1/55),   3.1 MiB (  6.3 KiB unpacked)
    In cache libX11-data-1.6.2-12.5.1.noarch.rpm                                                (2/55), 158.5 KiB (  1.6 MiB unpacked)
    In cache libatomic1-32bit-8.2.1+r264010-1.3.3.x86_64.rpm                                    (3/55),  15.6 KiB ( 21.4 KiB unpacked)
    In cache libatomic1-8.2.1+r264010-1.3.3.x86_64.rpm                                          (4/55),  16.1 KiB ( 26.1 KiB unpacked)
    In cache libgcc_s1-32bit-8.2.1+r264010-1.3.3.x86_64.rpm                                     (5/55),  52.0 KiB (109.5 KiB unpacked)
    In cache libgcc_s1-8.2.1+r264010-1.3.3.x86_64.rpm                                           (6/55),  46.6 KiB ( 94.4 KiB unpacked)
    In cache libgomp1-32bit-8.2.1+r264010-1.3.3.x86_64.rpm                                      (7/55),  99.9 KiB (239.5 KiB unpacked)
    In cache libgomp1-8.2.1+r264010-1.3.3.x86_64.rpm                                            (8/55), 102.2 KiB (255.7 KiB unpacked)
    In cache libitm1-32bit-8.2.1+r264010-1.3.3.x86_64.rpm                                       (9/55),  36.3 KiB (105.6 KiB unpacked)
    In cache libitm1-8.2.1+r264010-1.3.3.x86_64.rpm                                            (10/55),  34.5 KiB (110.4 KiB unpacked)
    In cache libreadline6-6.3-83.15.1.x86_64.rpm                                               (11/55), 154.5 KiB (332.6 KiB unpacked)
    In cache libwacom-data-0.9-2.4.2.x86_64.rpm                                                (12/55),  34.1 KiB (225.1 KiB unpacked)
    In cache libxcb1-1.10-4.3.1.x86_64.rpm                                                     (13/55),  40.2 KiB (126.9 KiB unpacked)
    In cache libX11-xcb1-1.6.2-12.5.1.x86_64.rpm                                               (14/55),  15.1 KiB (  5.9 KiB unpacked)
    In cache libstdc++6-32bit-8.2.1+r264010-1.3.3.x86_64.rpm                                   (15/55), 399.4 KiB (  1.5 MiB unpacked)
    In cache libstdc++6-8.2.1+r264010-1.3.3.x86_64.rpm                                         (16/55), 370.1 KiB (  1.5 MiB unpacked)
    In cache bash-4.3-83.15.1.x86_64.rpm                                                       (17/55), 382.9 KiB (746.5 KiB unpacked)
    In cache libwacom2-0.9-2.4.2.x86_64.rpm                                                    (18/55),  21.4 KiB ( 43.0 KiB unpacked)
    In cache libxcb-xv0-1.10-4.3.1.x86_64.rpm                                                  (19/55),  14.2 KiB ( 26.3 KiB unpacked)
    In cache libxcb-xkb1-1.10-4.3.1.x86_64.rpm                                                 (20/55),  32.6 KiB (106.6 KiB unpacked)
    In cache libxcb-xinerama0-1.10-4.3.1.x86_64.rpm                                            (21/55),  10.7 KiB ( 10.2 KiB unpacked)
    In cache libxcb-xfixes0-1.10-4.3.1.x86_64.rpm                                              (22/55),  13.7 KiB ( 26.2 KiB unpacked)
    In cache libxcb-xf86dri0-1.10-4.3.1.x86_64.rpm                                             (23/55),  11.6 KiB ( 18.2 KiB unpacked)
    In cache libxcb-sync1-1.10-4.3.1.x86_64.rpm                                                (24/55),  13.4 KiB ( 22.2 KiB unpacked)
    In cache libxcb-shm0-1.10-4.3.1.x86_64.rpm                                                 (25/55),  11.0 KiB ( 10.2 KiB unpacked)
    In cache libxcb-shape0-1.10-4.3.1.x86_64.rpm                                               (26/55),  11.1 KiB ( 14.2 KiB unpacked)
    In cache libxcb-render0-1.10-4.3.1.x86_64.rpm                                              (27/55),  15.9 KiB ( 38.2 KiB unpacked)
    In cache libxcb-randr0-1.10-4.3.1.x86_64.rpm                                               (28/55),  18.9 KiB ( 54.4 KiB unpacked)
    In cache libxcb-present0-1.10-4.3.1.x86_64.rpm                                             (29/55),  10.6 KiB ( 10.2 KiB unpacked)
    In cache libxcb-glx0-1.10-4.3.1.x86_64.rpm                                                 (30/55),  24.0 KiB ( 94.2 KiB unpacked)
    In cache libxcb-dri3-0-1.10-4.3.1.x86_64.rpm                                               (31/55),  10.6 KiB ( 10.2 KiB unpacked)
    In cache libxcb-dri2-0-1.10-4.3.1.x86_64.rpm                                               (32/55),  11.9 KiB ( 18.2 KiB unpacked)
    In cache libX11-6-1.6.2-12.5.1.x86_64.rpm                                                  (33/55), 548.0 KiB (  1.2 MiB unpacked)
    In cache libtsan0-8.2.1+r264010-1.3.3.x86_64.rpm                                           (34/55), 280.9 KiB (929.1 KiB unpacked)
    In cache readline-doc-6.3-83.15.1.noarch.rpm                                               (35/55), 198.1 KiB (695.6 KiB unpacked)
    Retrieving package xorg-x11-server-extra-7.6_1.18.3-76.21.2.x86_64                         (36/55),   1.3 MiB (  5.4 MiB unpacked)
    Retrieving delta: ./x86_64/xorg-x11-server-extra-7.6_1.18.3-76.15.2_76.21.2.x86_64.drpm, 377.2 KiB
    Retrieving: xorg-x11-server-extra-7.6_1.18.3-76.15.2_76.21.2.x86_64.drpm ...................................................[done]
    Applying delta: ./xorg-x11-server-extra-7.6_1.18.3-76.15.2_76.21.2.x86_64.drpm .............................................[done]
    In cache libMagickCore-6_Q16-1-6.8.8.1-71.79.1.x86_64.rpm                                  (37/55),   1.6 MiB (  6.1 MiB unpacked)
    In cache bash-doc-4.3-83.15.1.noarch.rpm                                                   (38/55), 531.2 KiB (  1.9 MiB unpacked)
    In cache libMagickWand-6_Q16-1-6.8.8.1-71.79.1.x86_64.rpm                                  (39/55), 323.9 KiB (  1.1 MiB unpacked)
    Retrieving package xorg-x11-server-7.6_1.18.3-76.21.2.x86_64                               (40/55),   1.5 MiB (  5.2 MiB unpacked)
    Retrieving delta: ./x86_64/xorg-x11-server-7.6_1.18.3-76.15.2_76.21.2.x86_64.drpm, 329.5 KiB
    Retrieving: xorg-x11-server-7.6_1.18.3-76.15.2_76.21.2.x86_64.drpm .........................................................[done]
    Applying delta: ./xorg-x11-server-7.6_1.18.3-76.15.2_76.21.2.x86_64.drpm ...................................................[done]
    In cache libxcb1-32bit-1.10-4.3.1.x86_64.rpm                                               (41/55),  42.8 KiB (137.8 KiB unpacked)
    In cache libX11-xcb1-32bit-1.6.2-12.5.1.x86_64.rpm                                         (42/55),  14.9 KiB (  5.3 KiB unpacked)
    In cache kernel-devel-4.4.156-94.61.1.noarch.rpm                                           (43/55),  13.5 MiB ( 52.6 MiB unpacked)
    In cache kernel-default-4.4.156-94.61.1.x86_64.rpm                                         (44/55),  39.1 MiB (167.4 MiB unpacked)
    In cache libxcb-xfixes0-32bit-1.10-4.3.1.x86_64.rpm                                        (45/55),  14.2 KiB ( 29.4 KiB unpacked)
    In cache libxcb-sync1-32bit-1.10-4.3.1.x86_64.rpm                                          (46/55),  13.6 KiB ( 21.5 KiB unpacked)
    In cache libxcb-shm0-32bit-1.10-4.3.1.x86_64.rpm                                           (47/55),  11.1 KiB (  9.4 KiB unpacked)
    In cache libxcb-render0-32bit-1.10-4.3.1.x86_64.rpm                                        (48/55),  16.7 KiB ( 37.5 KiB unpacked)
    In cache libxcb-present0-32bit-1.10-4.3.1.x86_64.rpm                                       (49/55),  10.6 KiB (  9.4 KiB unpacked)
    In cache libxcb-glx0-32bit-1.10-4.3.1.x86_64.rpm                                           (50/55),  25.6 KiB ( 97.4 KiB unpacked)
    In cache libxcb-dri3-0-32bit-1.10-4.3.1.x86_64.rpm                                         (51/55),  10.6 KiB (  9.4 KiB unpacked)
    In cache libxcb-dri2-0-32bit-1.10-4.3.1.x86_64.rpm                                         (52/55),  12.2 KiB ( 17.4 KiB unpacked)
    In cache libX11-6-32bit-1.6.2-12.5.1.x86_64.rpm                                            (53/55), 548.6 KiB (  1.2 MiB unpacked)
    In cache kernel-source-4.4.156-94.61.1.noarch.rpm                                          (54/55),  89.5 MiB (548.6 MiB unpacked)
    In cache kernel-default-devel-4.4.156-94.61.1.x86_64.rpm                                   (55/55),   5.2 MiB (  3.4 MiB unpacked)
    Checking for file conflicts: ...............................................................................................[done]
    ( 1/55) Installing: kernel-macros-4.4.156-94.61.1.noarch ...................................................................[done]
    ( 2/55) Installing: libX11-data-1.6.2-12.5.1.noarch ........................................................................[done]
    ( 3/55) Installing: libatomic1-32bit-8.2.1+r264010-1.3.3.x86_64 ............................................................[done]
    ( 4/55) Installing: libatomic1-8.2.1+r264010-1.3.3.x86_64 ..................................................................[done]
    ( 5/55) Installing: libgcc_s1-32bit-8.2.1+r264010-1.3.3.x86_64 .............................................................[done]
    ( 6/55) Installing: libgcc_s1-8.2.1+r264010-1.3.3.x86_64 ...................................................................[done]
    ( 7/55) Installing: libgomp1-32bit-8.2.1+r264010-1.3.3.x86_64 ..............................................................[done]
    ( 8/55) Installing: libgomp1-8.2.1+r264010-1.3.3.x86_64 ....................................................................[done]
    ( 9/55) Installing: libitm1-32bit-8.2.1+r264010-1.3.3.x86_64 ...............................................................[done]
    (10/55) Installing: libitm1-8.2.1+r264010-1.3.3.x86_64 .....................................................................[done]
    (11/55) Installing: libreadline6-6.3-83.15.1.x86_64 ........................................................................[done]
    (12/55) Installing: libwacom-data-0.9-2.4.2.x86_64 .........................................................................[done]
    (13/55) Installing: libxcb1-1.10-4.3.1.x86_64 ..............................................................................[done]
    (14/55) Installing: libX11-xcb1-1.6.2-12.5.1.x86_64 ........................................................................[done]
    (15/55) Installing: libstdc++6-32bit-8.2.1+r264010-1.3.3.x86_64 ............................................................[done]
    (16/55) Installing: libstdc++6-8.2.1+r264010-1.3.3.x86_64 ..................................................................[done]
    (17/55) Installing: bash-4.3-83.15.1.x86_64 ................................................................................[done]
    (18/55) Installing: libwacom2-0.9-2.4.2.x86_64 .............................................................................[done]
    (19/55) Installing: libxcb-xv0-1.10-4.3.1.x86_64 ...........................................................................[done]
    (20/55) Installing: libxcb-xkb1-1.10-4.3.1.x86_64 ..........................................................................[done]
    (21/55) Installing: libxcb-xinerama0-1.10-4.3.1.x86_64 .....................................................................[done]
    (22/55) Installing: libxcb-xfixes0-1.10-4.3.1.x86_64 .......................................................................[done]
    (23/55) Installing: libxcb-xf86dri0-1.10-4.3.1.x86_64 ......................................................................[done]
    (24/55) Installing: libxcb-sync1-1.10-4.3.1.x86_64 .........................................................................[done]
    (25/55) Installing: libxcb-shm0-1.10-4.3.1.x86_64 ..........................................................................[done]
    (26/55) Installing: libxcb-shape0-1.10-4.3.1.x86_64 ........................................................................[done]
    (27/55) Installing: libxcb-render0-1.10-4.3.1.x86_64 .......................................................................[done]
    (28/55) Installing: libxcb-randr0-1.10-4.3.1.x86_64 ........................................................................[done]
    (29/55) Installing: libxcb-present0-1.10-4.3.1.x86_64 ......................................................................[done]
    (30/55) Installing: libxcb-glx0-1.10-4.3.1.x86_64 ..........................................................................[done]
    (31/55) Installing: libxcb-dri3-0-1.10-4.3.1.x86_64 ........................................................................[done]
    (32/55) Installing: libxcb-dri2-0-1.10-4.3.1.x86_64 ........................................................................[done]
    (33/55) Installing: libX11-6-1.6.2-12.5.1.x86_64 ...........................................................................[done]
    (34/55) Installing: libtsan0-8.2.1+r264010-1.3.3.x86_64 ....................................................................[done]
    (35/55) Installing: readline-doc-6.3-83.15.1.noarch ........................................................................[done]
    (36/55) Installing: xorg-x11-server-extra-7.6_1.18.3-76.21.2.x86_64 ........................................................[done]
    (37/55) Installing: libMagickCore-6_Q16-1-6.8.8.1-71.79.1.x86_64 ...........................................................[done]
    (38/55) Installing: bash-doc-4.3-83.15.1.noarch ............................................................................[done]
    (39/55) Installing: libMagickWand-6_Q16-1-6.8.8.1-71.79.1.x86_64 ...........................................................[done]
    (40/55) Installing: xorg-x11-server-7.6_1.18.3-76.21.2.x86_64 ..............................................................[done]
    Additional rpm output:
    Updating /etc/sysconfig/displaymanager...
    
    
    (41/55) Installing: libxcb1-32bit-1.10-4.3.1.x86_64 ........................................................................[done]
    (42/55) Installing: libX11-xcb1-32bit-1.6.2-12.5.1.x86_64 ..................................................................[done]
    (43/55) Installing: kernel-devel-4.4.156-94.61.1.noarch ....................................................................[done]
    Additional rpm output:
    Changing symlink /usr/src/linux from linux-4.4.156-94.57 to linux-4.4.156-94.61
    
    
    (44/55) Installing: kernel-default-4.4.156-94.61.1.x86_64 ..................................................................[done]
    Additional rpm output:
    Creating initrd: /boot/initrd-4.4.156-94.61-default
    dracut: Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-4.4.156-94.61-default 4.4.156-94.61-default
    dracut: *** Including module: bash ***
    dracut: *** Including module: systemd ***
    dracut: *** Including module: warpclock ***
    dracut: *** Including module: systemd-initrd ***
    dracut: *** Including module: i18n ***
    dracut: *** Including module: drm ***
    dracut: *** Including module: plymouth ***
    dracut: *** Including module: dm ***
    dracut: Skipping udev rule: 64-device-mapper.rules
    dracut: Skipping udev rule: 60-persistent-storage-dm.rules
    dracut: Skipping udev rule: 55-dm.rules
    dracut: *** Including module: kernel-modules ***
    dracut: *** Including module: lvm ***
    dracut: Skipping udev rule: 64-device-mapper.rules
    dracut: Skipping udev rule: 56-lvm.rules
    dracut: Skipping udev rule: 60-persistent-storage-lvm.rules
    dracut: *** Including module: resume ***
    dracut: *** Including module: rootfs-block ***
    dracut: *** Including module: suse-btrfs ***
    dracut: *** Including module: suse-xfs ***
    dracut: *** Including module: terminfo ***
    dracut: *** Including module: udev-rules ***
    dracut: Skipping udev rule: 40-redhat.rules
    dracut: Skipping udev rule: 50-firmware.rules
    dracut: Skipping udev rule: 50-udev.rules
    dracut: Skipping udev rule: 91-permissions.rules
    dracut: Skipping udev rule: 80-drivers-modprobe.rules
    dracut: *** Including module: dracut-systemd ***
    dracut: *** Including module: haveged ***
    dracut: *** Including module: usrmount ***
    dracut: *** Including module: base ***
    dracut: *** Including module: fs-lib ***
    dracut: *** Including module: shutdown ***
    dracut: *** Including module: suse ***
    dracut: *** Including modules done ***
    dracut: *** Installing kernel module dependencies and firmware ***
    dracut: *** Installing kernel module dependencies and firmware done ***
    dracut: *** Resolving executable dependencies ***
    dracut: *** Resolving executable dependencies done***
    dracut: *** Hardlinking files ***
    dracut: *** Hardlinking files done ***
    dracut: *** Stripping files ***
    dracut: *** Stripping files done ***
    dracut: *** Generating early-microcode cpio image ***
    dracut: *** Constructing GenuineIntel.bin ****
    dracut: *** Store current command line parameters ***
    dracut: Stored kernel commandline:
    dracut:  rd.lvm.lv=system/root
     rd.lvm.lv=system/swap
    dracut:  resume=/dev/mapper/system-swap
    dracut:  root=/dev/mapper/system-root rootfstype=xfs rootflags=rw,relatime,attr2,inode64,noquota
    dracut: *** Creating image file '/boot/initrd-4.4.156-94.61-default' ***
    dracut: *** Creating initramfs image file '/boot/initrd-4.4.156-94.61-default' done ***
    
    
    (45/55) Installing: libxcb-xfixes0-32bit-1.10-4.3.1.x86_64 .................................................................[done]
    (46/55) Installing: libxcb-sync1-32bit-1.10-4.3.1.x86_64 ...................................................................[done]
    (47/55) Installing: libxcb-shm0-32bit-1.10-4.3.1.x86_64 ....................................................................[done]
    (48/55) Installing: libxcb-render0-32bit-1.10-4.3.1.x86_64 .................................................................[done]
    (49/55) Installing: libxcb-present0-32bit-1.10-4.3.1.x86_64 ................................................................[done]
    (50/55) Installing: libxcb-glx0-32bit-1.10-4.3.1.x86_64 ....................................................................[done]
    (51/55) Installing: libxcb-dri3-0-32bit-1.10-4.3.1.x86_64 ..................................................................[done]
    (52/55) Installing: libxcb-dri2-0-32bit-1.10-4.3.1.x86_64 ..................................................................[done]
    (53/55) Installing: libX11-6-32bit-1.6.2-12.5.1.x86_64 .....................................................................[done]
    (54/55) Installing: kernel-source-4.4.156-94.61.1.noarch ...................................................................[done]
    (55/55) Installing: kernel-default-devel-4.4.156-94.61.1.x86_64 ............................................................[done]
    Additional rpm output:
    Changing symlink /usr/src/linux-obj/x86_64/default from ../../linux-4.4.156-94.57-obj/x86_64/default to ../../linux-4.4.156-94.61-obj/x86_64/default
    
    
    There are some running programs that might use files deleted by recent upgrade. You may wish to check and restart some of them. Run 'zypper ps -s' to list these programs.
    server:~ # zypper in kernel-source kernel-syms libelf-devel module-init-tools make gcc rpmbuild
    Refreshing service 'SUSE_Linux_Enterprise_Server_for_SAP_Applications_12_SP3_x86_64'.
    Loading repository data...
    Reading installed packages...
    'libelf-devel' not found in package names. Trying capabilities.
    No provider of 'libelf-devel' found.
    'gcc' is already installed.
    No update candidate for 'gcc-4.8-6.189.x86_64'. The highest available version is already installed.
    'make' is already installed.
    No update candidate for 'make-4.0-4.1.x86_64'. The highest available version is already installed.
    'kernel-source' is already installed.
    No update candidate for 'kernel-source-4.4.156-94.61.1.noarch'. The highest available version is already installed.
    'module-init-tools' not found in package names. Trying capabilities.
    'kmod-compat' providing 'module-init-tools' is already installed.
    'rpmbuild' not found in package names. Trying capabilities.
    Resolving package dependencies...
    
    The following 7 NEW packages are going to be installed:
      gettext-tools kernel-syms mozilla-nss-tools pesign pesign-obs-integration rpm-build systemd-rpm-macros
    
    7 new packages to install.
    Overall download size: 5.4 MiB. Already cached: 0 B. After the operation, additional 10.1 MiB will be used.
    Continue? [y/n/...? shows all options] (y): y
    Retrieving package gettext-tools-0.19.2-1.103.x86_64                                         (1/7),   1.8 MiB (  7.9 MiB unpacked)
    Retrieving: gettext-tools-0.19.2-1.103.x86_64.rpm ............................................................[done (912.0 KiB/s)]
    Retrieving package mozilla-nss-tools-3.29.5-58.12.1.x86_64                                   (2/7), 391.3 KiB (  1.8 MiB unpacked)
    Retrieving: mozilla-nss-tools-3.29.5-58.12.1.x86_64.rpm ....................................................................[done]
    Retrieving package pesign-0.109-6.3.1.x86_64                                                 (3/7),  99.2 KiB (404.2 KiB unpacked)
    Retrieving: pesign-0.109-6.3.1.x86_64.rpm ..................................................................................[done]
    Retrieving package systemd-rpm-macros-3-10.9.1.noarch                                        (4/7),   9.0 KiB ( 12.0 KiB unpacked)
    Retrieving: systemd-rpm-macros-3-10.9.1.noarch.rpm .........................................................................[done]
    Retrieving package pesign-obs-integration-10.0-30.8.1.x86_64                                 (5/7),  27.1 KiB ( 58.6 KiB unpacked)
    Retrieving: pesign-obs-integration-10.0-30.8.1.x86_64.rpm ..................................................................[done]
    Retrieving package rpm-build-4.11.2-16.13.1.x86_64                                           (6/7),  34.8 KiB ( 24.6 KiB unpacked)
    Retrieving: rpm-build-4.11.2-16.13.1.x86_64.rpm ............................................................................[done]
    Retrieving package kernel-syms-4.4.156-94.61.1.x86_64                                        (7/7),   3.1 MiB (  345   B unpacked)
    Retrieving: kernel-syms-4.4.156-94.61.1.x86_64.rpm ...........................................................[done (943.9 KiB/s)]
    Checking for file conflicts: ...............................................................................................[done]
    (1/7) Installing: gettext-tools-0.19.2-1.103.x86_64 ........................................................................[done]
    (2/7) Installing: mozilla-nss-tools-3.29.5-58.12.1.x86_64 ..................................................................[done]
    (3/7) Installing: pesign-0.109-6.3.1.x86_64 ................................................................................[done]
    (4/7) Installing: systemd-rpm-macros-3-10.9.1.noarch .......................................................................[done]
    (5/7) Installing: pesign-obs-integration-10.0-30.8.1.x86_64 ................................................................[done]
    (6/7) Installing: rpm-build-4.11.2-16.13.1.x86_64 ..........................................................................[done]
    (7/7) Installing: kernel-syms-4.4.156-94.61.1.x86_64 .......................................................................[done]
    Installation has completed with error.
    server:~ # rpmbuild --rebuild sm750-4.4.73-3.1.src.rpm
    Installing sm750-4.4.73-3.1.src.rpm
    warning: sm750-4.4.73-3.1.src.rpm: Header V3 RSA/SHA256 Signature, key ID 3508c1dd: NOKEY
    error: Failed build dependencies:
            libelf-devel is needed by sm750-4.4.1564.4.156-3.1.x86_64
    One off-topic: I'm trying to edit the last message to correct a mistake, but I can't find the option. I don't know If I can do it or not.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •