I try to rebuild openblas binary RPM from its source rpm, run rpmbuild, but got "
hpc_init not defined in spec file erros,
then I run build script :

#build openblas.spec,

but got following errors:

[ 0s] hp-bdw started "build openblas.spec" at Thu Oct 18 07:34:12 UTC 2018.
[ 0s]
[ 0s]
[ 0s] processing recipe /usr/src/packages/./SPECS/openblas.spec ...
[ 0s] init_buildsystem --configdir /usr/lib/build/configs --cachedir /var/cache/build --repository zypp:// /usr/src/packages/./SPECS/openblas.spec ...
[ 0s] It seems that there was an incomplete setup of /var/tmp/build-root.
[ 0s] To be sure, we will build it again completely...
[ 0s] Your build system is broken!! Shall I execute
[ 0s]
[ 0s] rm -rf -- /var/tmp/build-root/*
[ 0s]
[ 0s] y - yes, cleanup the build root
[ 0s] N - No, abort build (default on enter)
[ 0s] c - Continue anyway with this build root
[ 3s] [y/N/c] initializing /var/tmp/build-root/.srcfiles.cache ...
[ 3s] /usr/lib/build/createzyppdeps --cachedir=/var/cache/build zypp://Basesystem_Module_15_x86_64:SLE-Module-Basesystem15-Pool
[ 4s] /usr/lib/build/createzyppdeps --cachedir=/var/cache/build zypp://Basesystem_Module_15_x86_64:SLE-Module-Basesystem15-Updates
[ 5s] /usr/lib/build/createzyppdeps --cachedir=/var/cache/build zypp://Desktop_Applications_Module_15_x86_64:SLE-Module-Desktop-Applications15-Pool
[ 7s] /usr/lib/build/createzyppdeps --cachedir=/var/cache/build zypp://Desktop_Applications_Module_15_x86_64:SLE-Module-Desktop-Applications15-Updates
[ 7s] /usr/lib/build/createzyppdeps --cachedir=/var/cache/build zypp://Development-Tools-Module_15-0
[ 7s] zypp repo zypp://Development-Tools-Module_15-0 is not up to date, please refresh first
[ 7s]
[ 7s] hp-bdw failed "build openblas.spec" at Thu Oct 18 07:34:19 UTC 2018.

So I refresh the repos first,

#zypper ref -fdb

then rerun the build, still got the same errors.

After yast online update all packages and repos,
the same result,

What is the step to build rpm under HPC

Thanks in advance.