Results 1 to 4 of 4

Thread: ha-cluster script return error for default network interface

  1. #1

    ha-cluster script return error for default network interface

    Hello SME,

    I'm testing SLES12 SP3 HA Extension. When running ha-cluster-init in node 1, it returns error message as follows. From the man page, it mentions eth0 is the default network interface. Don't understand why it cannot detect the network card. The workaround is to use -i option to specify eth0 and looks worked fine. When running ha-cluster-join in node 2, it returns the same error message. But this time, that workaround doesn't work and it returns another error message as follows. I verified that node 1 and node 2 are able to login with each others via ssh without password. Do you have any idea to solve it?

    In node 1
    ======
    ha-cluster-init
    "ERROR: cluster.init: Failed to determine default network interface"

    hc-cluster-init -i eth0
    ......
    ......
    Done (log saved to /var/log/ha-cluster-bootstrap.log)


    In node 2
    ======
    ha-cluster-join
    ERROR: cluster.join: Failed to determine default network interface

    ha-cluster-join -i eth0
    ......
    ......
    ERROR: 1: cluster.join: Can't invoke ha-cluster-init ssh_remote on 192.168.10.11

  2. Re: ha-cluster script return error for default network inter

    Hi collinsyunkk,

    had you checked what's in the logs (i. e. /var/log/ha-cluster-bootstrap.log) when running cluster-init without "-i"? Also, does "ip a" report anything unusual?

    Regards,
    J
    From the times when today's "old school" was "new school"

    If you find this post helpful and are logged into the web interface, show your appreciation and click on the star below...

  3. #3

    Re: ha-cluster script return error for default network inter

    Quote Originally Posted by jmozdzen View Post
    Hi collinsyunkk,

    had you checked what's in the logs (i. e. /var/log/ha-cluster-bootstrap.log) when running cluster-init without "-i"? Also, does "ip a" report anything unusual?

    Regards,
    J

    Hello jmozdzen,

    Thanks for your comment. After read the log, I got a hint to turn on debug mode when running the crm command which called by ha-cluster-join. The issue is fixed by adding default gateway in both node 1 and 2 (even if both nodes are located at the same subnet).

    Regards,
    Collins

  4. Re: ha-cluster script return error for default network inter

    Hi Collins,

    thank you for sharing your findings - I wouldn't have put my guess on a missing default route, indeed. Glad you found that out and got it running!

    Regards,
    J
    From the times when today's "old school" was "new school"

    If you find this post helpful and are logged into the web interface, show your appreciation and click on the star below...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •