Dear SUSE colleagues,

I got a serious problem of losing the x windows for my server. I am using SUSE Linux Enterprise Server 11 (x86_64), with the patch level of 1. A couple of weeks ago, I did a system update from Yast. Everything worked fine except that the x window disappeared (became black screen) immediately after updating.

I restarted the system and input "startx" on the console. But it always stuck somewhere and show me a black screen. However, everything else ran great. I can ssh to it, do various calculation, and visit the apache server running on it.

I searched online and tried several times to restored the x windows system, but failed. Could you guys help figure out what is the problem?

I appreciate it very much.

The following is the information stored in the file ~/.xsession-errors.


X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux-eg 2.6.32.59-0.3-default #1 SMP 2012-04-27 11:14:44
+0200 x86_64
Build Date: 19 December 2011 06:05:06PM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jul 18 17:24:09 2012
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "freetype" (module does not exist, 0)
(EE) MGA(0): [drm] Direct rendering only supported with G200/G400/G450/G550.
(EE) config/hal: NewInputDeviceRequest failed (8)
(EE) config/hal: NewInputDeviceRequest failed (8)
(EE) config/hal: NewInputDeviceRequest failed (8)
(EE) config/hal: NewInputDeviceRequest failed (8)
/etc/X11/xim: Checking whether an input method should be started.
/etc/X11/xim: user environment variable LANG=en_US.UTF-8
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale en_US.UTF-8 ...
There is no default input method for the current locale.
Dummy input method "none" (do not use any fancy input method by default)
GNOME_KEYRING_SOCKET=/tmp/keyring-2yVAzb/socket
SSH_AUTH_SOCK=/tmp/keyring-2yVAzb/socket.ssh
GNOME_KEYRING_PID=2843
/usr/lib/gnome-settings-daemon/gnome-settings-daemon: symbol lookup error: /usr/lib64/gio
/modules/libdconfsettings.so: undefined symbol: g_settings_backend_get_type
Window manager warning: Failed to read saved session file /home/david/.config/metacity/se
ssions/1078c31dcc2411dc451342646651151200000028160015.ms: Failed to open file '/home/davi
d/.config/metacity/sessions/1078c31dcc2411dc451342646651151200000028160015.ms' : No such f
ile or directory
gnome-panel: symbol lookup error: /usr/lib64/gio/modules/libdconfsettings.so: undefined s
ymbol: g_settings_backend_get_type
nautilus: symbol lookup error: /usr/lib64/gio/modules/libdconfsettings.so: undefined symb
ol: g_settings_backend_get_type
Exit: gpk_check_privileged_user returned FALSE
Traceback (most recent call last):
File "/usr/lib64/python2.6/site-packages/system-config-printer/applet.py", line 20, in
<module>
import cups
ImportError: No module named cups
gnome-volume-control-applet: symbol lookup error: /usr/lib64/gio/modules/libdconfsettings
.so: undefined symbol: g_settings_backend_get_type

Thanks,

David