Upgraded from SLES 12 SP4 + HA to SLES 15 + HA
Using DRBD on devices & HA cluster to have HA on the DRBD devices

after the upgrade, DRBD will not start

ISSUE
nss-sn01:/ # drbdadm status
modinfo: ERROR: Module drbd not found.
modinfo: ERROR: Module drbd not found.
modprobe: FATAL: Module drbd not found in directory /lib/modules/4.12.14-95.3-default
Failed to modprobe drbd (No such file or directory)
Command 'drbdsetup status' terminated with exit code 20
command status exited with code 20

---


nss-sn01:/ # rpm -qa | grep drbd
yast2-drbd-4.0.3-3.3.1.noarch
drbd-9.0.13+git.b83ade31-3.2.1.x86_64
drbd-utils-9.3.1-1.21.x86_64
drbd-kmp-default-9.0.13+git.b83ade31_k4.12.14_23-3.2.1.x86_64

nss-sn01:/ # systemctl status drbd -l
● drbd.service - DRBD -- please disable. Unless you are NOT using a cluster manager.
Loaded: loaded (/usr/lib/systemd/system/drbd.service; disabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Wed 2019-02-13 22:05:13 MST; 13min ago
Main PID: 13357 (code=exited, status=5)

Feb 13 22:05:13 nss-sn01 systemd[1]: Starting DRBD -- please disable. Unless you are NOT using a cluster manager....
Feb 13 22:05:13 nss-sn01 drbd[13357]: /lib/drbd/drbd: line 58: local: can only be used in a function
Feb 13 22:05:13 nss-sn01 modprobe[13370]: FATAL: Module drbd not found in directory /lib/modules/4.12.14-95.3-default
Feb 13 22:05:13 nss-sn01 drbd[13357]: Can not load the drbd module.
Feb 13 22:05:13 nss-sn01 systemd[1]: drbd.service: Main process exited, code=exited, status=5/NOTINSTALLED
Feb 13 22:05:13 nss-sn01 systemd[1]: Failed to start DRBD -- please disable. Unless you are NOT using a cluster manager..
Feb 13 22:05:13 nss-sn01 systemd[1]: drbd.service: Unit entered failed state.
Feb 13 22:05:13 nss-sn01 systemd[1]: drbd.service: Failed with result 'exit-code'.

nss-sn01:/ # uname -a
Linux nss-sn01 4.12.14-95.3-default #1 SMP Wed Dec 5 06:00:48 UTC 2018 (63a8d29) x86_64 x86_64 x86_64 GNU/Linux

nss-sn01:/ # cat /etc/os-release
NAME="SLES"
VERSION="15"
VERSION_ID="15"
PRETTY_NAME="SUSE Linux Enterprise Server 15"
ID="sles"
ID_LIKE="suse"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:suse:sles:15"

---
Don't know if this has anything to do with this, but some files are missing compared to a working SLES12 SP4 + HA
nss-sn01:/lib/modules/4.12.14-95.3-default # l weak-updates/updates/
total 4
drwxr-xr-x 1 root root 16 Feb 13 21:00 ./
drwxr-xr-x 1 root root 14 Dec 14 18:47 ../
lrwxrwxrwx 1 root root 51 Dec 14 18:47 crash.ko -> /lib/modules/4.12.14-94.41-default/updates/crash.ko
nss-sn01:/lib/modules/4.12.14-95.3-default #

--

used yast to updated the drbd modules - dd not help

Any comments, suggestion, fixes?