Results 1 to 5 of 5

Thread: Yast fails updates -- can't write to file

  1. #1

    Yast fails updates -- can't write to file

    I am trying to apply updates to my system using Yast2. I get the following message:

    "An error occurred during repository initialization. Error refreshing service SUSE_Package_Hub_15_x86_64 (https://scc.suse.com/access/services...ub_15_x86_64): Can't open file '/etc/zypp/repos.d/SUSE_Package_Hub_15_x86_64:SLE-Module-Packagehub-Subpackages15-Source-Pool.repo' for writing.
    I've gone to the file indicated and checked the ownership and it is root/root with read/write authority. And I can use kate to open it. I do not understand the problem so short of re-installing SLED 15, is there a fast fix for problems like this?

    And believe me, re-isntallin SLED 15 is painful because of the UEFI Bios of this motherboard. Half the time when I have to reboot because of some kernel patch I can't get it to start again without resorting to a recovery boot.

  2. Re: Yast fails updates -- can't write to file

    Hi
    Likely fallout from Infrastructure issues on Friday, the Leap 15 repositories went south (https://status.opensuse.org/incidents/184), probably influenced the package hub repository state. I would guess that some/all of package hub (SLE backports) is likely rebuilding and it may take awhile for things to get re-published.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Re: Yast fails updates -- can't write to file

    Any idea when they will have everything fixed, and what I will have to do to get things working correctly? I'm not going to be surprised if I have to re-install SLED 15. (Third time to try to post this...).

  4. Re: Yast fails updates -- can't write to file

    On Wed 27 Mar 2019 10:54:01 PM CDT, wylbur wrote:

    Any idea when they will have everything fixed, and what I will have to
    do to get things working correctly? I'm not going to be surprised if I
    have to re-install SLED 15. (Third time to try to post this...).
    Hi
    Not sure, I see the repos on OBS, if you try and force a refresh, does
    that help;

    Code:
    zypper -vvv -f ref
    I see this: https://lists.opensuse.org/opensuse-.../msg00040.html

    You also might try removing PackageHub and then re-add via SUSEConnect.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.28-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  5. #5

    Re: Yast fails updates -- can't write to file

    I had tried it several hours after your post and it failed. So I figured there were still problems. So I tried it again again 10 minutes ago and this time it ran without error. BTW "-f" is not recognized. Only vvv -ref .

    I also tried Yast's Online Update and this time it ran fine and installed several patches.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •