I have a need to compile openldap to turn on the debug messages. I added repositories for the “SUSE Linux Enterprise Software Development Kit 12 SP4 s390x” and ““SUSE Package Hub 12 SP4 s390x” in order to obtain the source for openldap2. When I run command 'zypper si openldap2' it comes back stating "nothing provides krb5-mini needed by openldap2...".

I found a thread from 2015 asking for the location of krb5-mini but there was nothing posted after the OP provided the number of the SR that had been opened.

I am looking to compile openldap2 to enable debug messages as I have 6 SLES 12 SP3 hosts that I can't get joined to AD. SP3 was supported in February when I ran into this issue. The 'net ads join...' command results in "Insufficient Access Authority". The command is being issued by root with the userid for the senior AD administrator. He enters his password when prompted.

IBM provides technical support and they escalated this issue to SUSE. SUSE said that they were able to do a join but that they don't have much experience with AD and wouldn't be able to provide any more help. They had to install AD and configure it to run the test.

One of my teammates wants the debug messages from openldap2 so that he can try to figure out what is wrong.

Other SLES 12 SP3 hosts were able to join AD successfully using the same 'net ads join...' command (and AD administrator id).