Hi

I cannot seem to get my SLES 12 OS onto the network.
eth0 and eth1 are physical
eth2 + eth3 + eth4 are Virtual cards coming from the VIO servers on IBM Power8 Harwdare
dmesg output listed below.Any ideas what this could be?

REMOVED:/etc # cat SuSE-release
SUSE Linux Enterprise Server 12 (ppc64le)
VERSION = 12
PATCHLEVEL = 3


REMOVED:~ # ip link list
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
link/ether b6:0d:02:b6:ba:02 brd ff:ff:ff:ff:ff:ff
3: eth2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
link/ether b6:0d:02:b6:ba:03 brd ff:ff:ff:ff:ff:ff
4: eth4: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
link/ether b6:0d:02:b6:ba:04 brd ff:ff:ff:ff:ff:ff
5: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq portid 98be94604bb0 state DOWN mode DEFAULT group default qlen 1000
link/ether 98:be:94:60:4b:b0 brd ff:ff:ff:ff:ff:ff
6: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq portid 98be94604bb2 state DOWN mode DEFAULT group default qlen 1000
link/ether 98:be:94:60:4b:b2 brd ff:ff:ff:ff:ff:ff
REMOVED:~ #
REMOVED:~ # ethtool eth0
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 100baseT/Half 100baseT/Full
1000baseT/Full
10000baseT/Full
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Advertised link modes: 100baseT/Half 100baseT/Full
1000baseT/Full
10000baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Speed: Unknown!
Duplex: Unknown! (255)
Port: Twisted Pair
PHYAD: 16
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Supports Wake-on: d
Wake-on: d
Current message level: 0x00000000 (0)

Link detected: no

REMOVED# ethtool -i eth0
driver: bnx2x
version: 1.712.30-0
firmware-version: bc 7.10.4 phy 1.34
expansion-rom-version:
bus-info: 0002:01:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: yes

REMOVED:/etc # dmesg|egrep "bnx|eth"
[ 23.148093] bnx2x: QLogic 5771x/578xx 10/20-Gigabit Ethernet Driver bnx2x 1.712.30-0 (2014/02/10)
[ 23.155483] bnx2x 0002:01:00.0: msix capability found
[ 23.156231] bnx2x 0002:01:00.0: enabling device (0140 -> 0142)
[ 23.165149] bnx2x 0002:01:00.0: ibm,query-pe-dma-windows(53) 10000 8000000 20000025 returned 0
[ 23.216101] bnx2x 0002:01:00.0: ibm,create-pe-dma-window(54) 10000 8000000 20000025 10 29 returned 0 (liobn = 0x70000025 starting addr = 8000000 0)
[ 23.375430] ibmveth: externally supported module, setting X kernel taint flag.
[ 23.375480] ibmveth: IBM Power Virtual Ethernet Driver 1.06
[ 23.464965] ibmveth 30000002 eth3: renamed from eth0
[ 25.068765] bnx2x 0002:01:00.0: Using 64-bit direct DMA at offset 800000000000000
[ 25.069193] bnx2x 0002:01:00.0: part number 0-0-0-0
[ 25.203063] ibmveth 30000003 rename3: renamed from eth1
[ 25.302799] ibmveth 30000004 eth4: renamed from eth2
[ 25.383856] ibmveth 30000003 eth2: renamed from rename3
[ 25.384022] bnx2x 0002:01:00.1: msix capability found
[ 25.384229] bnx2x 0002:01:00.1: enabling device (0140 -> 0142)
[ 25.386959] bnx2x 0002:01:00.1: Using 64-bit direct DMA at offset 800000000000000
[ 25.387295] bnx2x 0002:01:00.1: part number 0-0-0-0
[ 148.734390] bnx2x 0002:01:00.0 eth0: using MSI-X IRQs: sp 39 fp[0] 41 ... fp[7] 48
[ 149.854097] bnx2x 0002:01:00.1 eth1: using MSI-X IRQs: sp 49 fp[0] 51 ... fp[7] 66
REMOVED:/etc #