Check the following:

Code:
man mount.cifs
If yours is like mine, you need to have usrename and password, not user
and pass, as your options:

Code:
OPTIONS
username=arg
specifies the username to connect as. If this is not given, then the
environment variable USER is used.

Earlier versions of mount.cifs also allowed one to specify the username
in a "user%password" or "workgroup/user" or "workgroup/user%password" to
allow the password and workgroup to be specified as part of the username.
Support for those alternate username formats is now deprecated and should
no longer be used. Users should use the discrete "password=" and "domain="
to specify those values. While some versions of the cifs kernel module
accept "user=" as an abbreviation for this option, its use can confuse the
standard mount program into thinking that this is a non-superuser mount.
It is therefore recommended to use the full "username=" option name.

password=arg
specifies the CIFS password. If this option is not given then the
environment variable PASSWD is used. If the password is not specified
directly or indirectly via an argument to mount, mount.cifs will prompt
for a password, unless the guest option is specified.

Note that a password which contains the delimiter character (i.e. a
comma ´,´) will fail to be parsed correctly on the command line. However,
the same password defined in the PASSWD environment variable or via a
credentials file (see below) or entered at the password prompt will be
read correctly.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.