Quote Originally Posted by pier andreit
oook, :-)) if it helps:
My videocard is radeon HD 7310 graphics on SLE11 (maybe sp2 I don't
the one the thread referes to is a 6310 on opensuse 11.4

I ran the first script from 'here:'

for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print
"\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do sed -i
"s/$x/\x90\x90\x90\x90\x90/g" $DRIVER done

as superuser, the result was this:

pla@linux-hp655:~> su
linux-hp655:/home/pla # cd bin
linux-hp655:/home/pla/bin # sh fixwatermark1.sh
objdump: '/usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so': No such
file linux-hp655:/home/pla/bin #

I ran the second script:

DRIVER=$(find /usr/lib*/xorg/modules/drivers -name "fglrx_drv.so" |
head -1) SEDCMD=$(objdump -d $DRIVER | awk '/call/&&/EnableLogo/
{printf "s|\\x%s\\x%s\\x%s\\x%s\\x%s|\\x90\\x90\\x90\\x90\ \x90|;", $2,
$3, $4, $5, $6}') cp $DRIVER{,.org} sed -i "$SEDCMD" ${DRIVER}

as superuser, after some seconds the result was this:

fixwatermark1.sh fixwatermark2.sh
linux-hp655:/home/pla/bin # sh fixwatermark2.sh
fixwatermark2.sh: line 13: syntax error near unexpected token `done'
fixwatermark2.sh: line 13: `done'
linux-hp655:/home/pla/bin #

I don't know if the scripts did something or the errors occurred didn't
allowed to perform, but the watermark is still there.:-))

a little offtopic, what do you think about to get rid of sle11 and
install 12.1??
I tried with a spare hard disk of my old laptop to install 12.1, it
seems to works well, I can install the kde4.9, and the touchpad works
better, installed atiupgrade and installed last ati driver and it seems
to works quite well, it has the watermark as well,
I tried to upgrade to 4.9 in sle11 but a lot of dependencies popped up,
so I gived up.
is there as your opinion some good reason to remain in SLE11 ??? or bad
reasons to install opensuse 12.1??

thanks, ciao, pier

It all depends on your requirements, I multiboot between openSUSE, SLED
and SLES on this machine, I just tend to spend more time in SLED for
stability. I roll my own packages if I really need something specific on
the Open Build Service.

I also use vmware player and kvm to fire up others to test out.

I would wait until 12.2 is out next month if your going to look at
openSUSE, you can always download a live cd (RC2) and boot from that to
see how it goes.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 14 days 10:32, 2 users, load average: 0.39, 0.32, 0.32
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU