This is actually a salt state related to the packages.
We had an issue with sles-release and the countepart for SLES for SAP and this prevented applying high states , or even dist upgrade.
The workaround is to set "sles-release" for sap-based SLES to "unmanaged".

This kind of issue should be fixed in the updates, but we haven't updated yet ...