Results 1 to 2 of 2

Thread: Can't install Perl modules for Veeam

  1. Can't install Perl modules for Veeam

    I am trying to install the perl modules for SOAP so that I can do file level restore from a Veeam backup system on a SLES 11 SP4 server. I load "perl -MCPAN -e shell", then at the cpan prompt type "install SOAP::Lite".

    It does some things then comes back with:

    Warning: prerequisite Test::Requires 0.06 not found.
    'META_MERGE' is not a known MakeMaker parameter name.
    Writing Makefile for XML::Parser::Lite
    Could not read '/root/.cpan/build/XML-Parser-Lite-0.722-MgImHS/META.yml'. Falling back to other methods to determine prerequisites
    ---- Unsatisfied dependencies detected during ----
    ---- PHRED/XML-Parser-Lite-0.722.tar.gz ----

    also I see:

    ExtUtils::MakeMaker version 6.64 required--this is only version 6.42 at Makefile.PL line 9.
    BEGIN failed--compilation aborted at Makefile.PL line 9.
    Warning: No success on command[/usr/bin/perl Makefile.PL]
    Warning (usually harmless): 'YAML' not installed, will not store persistent state
    TOKUHIROM/Test-Requires-0.10.tar.gz
    /usr/bin/perl Makefile.PL -- NOT OK


    Unfortunately I am not a linux guru and just know enough linux to be dangerous. What do I need to do to get SOAP installed?

    Thanks,

    Dan

  2. Re: Can't install Perl modules for Veeam

    Quote Originally Posted by dchunt View Post
    I am trying to install the perl modules for SOAP so that I can do file level restore from a Veeam backup system on a SLES 11 SP4 server. I load "perl -MCPAN -e shell", then at the cpan prompt type "install SOAP::Lite".

    It does some things then comes back with:

    Warning: prerequisite Test::Requires 0.06 not found.
    'META_MERGE' is not a known MakeMaker parameter name.
    Writing Makefile for XML::Parser::Lite
    Could not read '/root/.cpan/build/XML-Parser-Lite-0.722-MgImHS/META.yml'. Falling back to other methods to determine prerequisites
    ---- Unsatisfied dependencies detected during ----
    ---- PHRED/XML-Parser-Lite-0.722.tar.gz ----

    also I see:

    ExtUtils::MakeMaker version 6.64 required--this is only version 6.42 at Makefile.PL line 9.
    BEGIN failed--compilation aborted at Makefile.PL line 9.
    Warning: No success on command[/usr/bin/perl Makefile.PL]
    Warning (usually harmless): 'YAML' not installed, will not store persistent state
    TOKUHIROM/Test-Requires-0.10.tar.gz
    /usr/bin/perl Makefile.PL -- NOT OK


    Unfortunately I am not a linux guru and just know enough linux to be dangerous. What do I need to do to get SOAP installed?

    Thanks,

    Dan
    Hi
    Use the zypper command to check/search the likes of perl-Test-Requires and perl-YAML can be installed via rpm first, else you should be able to install dependencies automatically via the cpan command. Have a read here: http://www.cpan.org/modules/INSTALL.html
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •