Results 1 to 2 of 2

Thread: Install Oracle 18c XE on SLES 12 SP3

  1. #1

    Install Oracle 18c XE on SLES 12 SP3

    Hello Guys
    I need help with installation of Oracle 18c XE on SLES 12 SP3.
    I did check oracle documentations for 18c XE but found only install guide for centos, RHEL and OL. In small part of installation guide document they mentioned minimum requirements Susse 12 SP1, so i supposed that is possible install this Oracle database in SLES 12 SP3.

    I was successfully prepared kernel settings and environment, but when i try rpm -ivh oracle-database-xe-18c-1.0-1.x86_64.rpm, getting the following error:

    error: Failed dependencies:
    oracle-database-preinstall-18c is needed by oracle-database-xe-18c-1.0-1.x86_64.

    So after this error i was try to install rpm -ivh oracle-database-preinstall-18c.rpm, and here also get next error:

    error: Failed dependencies:
    /etc/redhat-release is needed by oracle-database-preinstall-18c-1.0-1.el7.x86_64
    compat-libcap1 is needed by oracle-database-preinstall-18c-1.0-1.el7.x86_64
    compat-libstdc++-33 is needed by oracle-database-preinstall-18c-1.0-1.el7.x86_64
    initscripts is needed by oracle-database-preinstall-18c-1.0-1.el7.x86_64
    libgcc is needed by oracle-database-preinstall-18c-1.0-1.el7.x86_64
    libstdc++ is needed by oracle-database-preinstall-18c-1.0-1.el7.x86_64
    openssh-clients is needed by oracle-database-preinstall-18c-1.0-1.el7.x86_64
    util-linux-ng is needed by oracle-database-preinstall-18c-1.0-1.el7.x86_64
    xorg-x11-utils is needed by oracle-database-preinstall-18c-1.0-1.el7.x86_64
    Of course this packages not exist in SLES, and i'm pretty desperate.

    If somebody already installed Oracle 18c XE on Susse linux i would be very appreciated to share information.

    with regards
    Boris

  2. #2

    Re: Install Oracle 18c XE on SLES 12 SP3

    Hi Boris,
    It look likes for only rhel7 ora oel7.
    You can look at;
    Package requirements for SUSE Linux Enterprise Server 12
    https://docs.oracle.com/en/database/...F-094D53C76900
    You can install them manually via zypper. Then configure kernel parameters by hand. Its is not so hard.

    Good luck.
    Remzi

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •