Quote Originally Posted by kenjlin View Post
malcolmlewis thanks for your suggestion!
I tried the command, but eth0 is still trapped in the setup-in-progress status.
Code:
DL380G10R3S10:~ # ip link set eth0 up
DL380G10R3S10:~ # ifstatus eth0
eth0            setup-in-progress
      link:     #2, state up, mtu 1500
      type:     ethernet, hwaddr 98:f2:b3:ef:07:0e
      config:   compat:suse:/etc/sysconfig/network/ifcfg-eth0
      leases:   ipv4 dhcp requesting
      leases:   ipv6 dhcp requesting
There're 5 interfaces (eth0, eth4, eth5, eth6, eth7) requesting dhcp4 ip in my system.
In normal cases (eth4 to eth7), I can find 3 timeout in state VALIDATING for each of them,
while in the case of eth0, only 2 timeout in state VALIDATING can be seen: the last timeout doesn't happen.
Below are lines in the system messages by grep "timeout in state":
Code:
2019-06-05T02:18:24.426602-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth5: timeout in state INIT
2019-06-05T02:18:24.605244-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth4: timeout in state INIT
2019-06-05T02:18:25.018864-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth6: timeout in state INIT
2019-06-05T02:18:25.267331-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth7: timeout in state INIT
2019-06-05T02:18:26.296874-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth0: timeout in state INIT
2019-06-05T02:18:28.383760-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth5: timeout in state VALIDATING
2019-06-05T02:18:28.474400-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth4: timeout in state VALIDATING
2019-06-05T02:18:28.598274-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth5: timeout in state VALIDATING
2019-06-05T02:18:28.654751-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth4: timeout in state VALIDATING
2019-06-05T02:18:28.784714-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth5: timeout in state VALIDATING
2019-06-05T02:18:28.857638-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth4: timeout in state VALIDATING
2019-06-05T02:18:28.983572-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth7: timeout in state VALIDATING
2019-06-05T02:18:29.183763-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth7: timeout in state VALIDATING
2019-06-05T02:18:29.384072-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth7: timeout in state VALIDATING
2019-06-05T02:18:30.131474-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth6: timeout in state VALIDATING
2019-06-05T02:18:30.227965-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth0: timeout in state VALIDATING
2019-06-05T02:18:30.331468-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth6: timeout in state VALIDATING
2019-06-05T02:18:30.427701-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth0: timeout in state VALIDATING
2019-06-05T02:18:30.530706-05:00 DL380G10R3S15 wickedd-dhcp4[1387]: eth6: timeout in state VALIDATING
Wondering the reason that makes eth0 lose its last timeout in state VALIDATING...?

BTW, I tried to commented out line#843 that calls ni_dhcp4_fsm_validate_lease() to workaround the problem, and it seems workable.
https://github.com/openSUSE/wicked/b...cp4/fsm.c#L843
Do you know how to turn off the DHCP4_DO_ARP flag in the right config way? Any side-effect to disable it? Thank you.

Ken
Hi Ken
From the man 5 ifcfg shows a /etc/sysconfig/network/ifcfg-* option of;
Code:
SEND_GRATUITOUS_ARP=auto/yes/no
Try no and see what happens.

Can you try bringing up just one interface, wait a few seconds and bring the next one up etc with the ip command?