Results 1 to 6 of 6

Thread: Upgrade Issue/Registration server invalid system credentials

  1. #1

    Upgrade Issue/Registration server invalid system credentials

    Hello together,

    I´m trying to get a SLES12 SP4 to SLES 15 but I always fail the time setup checks the registration server:

    First message: Error connection to Registration Server failed Details: Invalid System credentials

    Second Message: Check that System is known to the registraion Server. Upgrade from NCC to SCC might take a Long time ans if SLE11 System (no it is a SLES12 System) was installed recently you could speed up by login to SCC

    SCC shows the System I also deregistered and registered it new. But nothing seems to help.

    So how do I SCC to accept my system? What is the secret?

    Regards,

    Andreas

  2. Re: Upgrade Issue/Registration server invalid system credent

    Quote Originally Posted by astock View Post
    Hello together,

    I´m trying to get a SLES12 SP4 to SLES 15 but I always fail the time setup checks the registration server:

    First message: Error connection to Registration Server failed Details: Invalid System credentials

    Second Message: Check that System is known to the registraion Server. Upgrade from NCC to SCC might take a Long time ans if SLE11 System (no it is a SLES12 System) was installed recently you could speed up by login to SCC

    SCC shows the System I also deregistered and registered it new. But nothing seems to help.

    So how do I SCC to accept my system? What is the secret?

    Regards,

    Andreas
    Hi Andreas
    When you de-registered the system, I'm assuming you used SUSEConnect and also cleaned up the system, eg;

    Code:
    SUSEConnect -d
    SUSEConnect --cleanup
    Then re-register with email, reg code(s) etc.

    How are you performing the migration?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Re: Upgrade Issue/Registration server invalid system credent

    Hello Malcolm,

    thanks for your reply, well the "manual" I used was TID 3303599 ( https://support.microfocus.com/kb/doc.php?id=3303599 ) which does mention --cleanup and --deregister but to the time the TID was released this options where future music. But I think basically it´s doing the same. And yes afterwards SUSEConnect -r <YourActivationCode> -e <YourEmailAddress> --debug &> /tmp/reg.log to register the system again.

    I insert the ISO to the virtual machine start up, choose Upgrade in boot menu, make the settings needed, configure network settings (identical to the normal operation of the machine), see system partition to update then accept license agreement, accept removed repositories well and then there are the two errors.

    Regards

    Andreas

  4. Re: Upgrade Issue/Registration server invalid system credent

    Quote Originally Posted by astock View Post
    Hello Malcolm,

    thanks for your reply, well the "manual" I used was TID 3303599 ( https://support.microfocus.com/kb/doc.php?id=3303599 ) which does mention --cleanup and --deregister but to the time the TID was released this options where future music. But I think basically it´s doing the same. And yes afterwards SUSEConnect -r <YourActivationCode> -e <YourEmailAddress> --debug &> /tmp/reg.log to register the system again.

    I insert the ISO to the virtual machine start up, choose Upgrade in boot menu, make the settings needed, configure network settings (identical to the normal operation of the machine), see system partition to update then accept license agreement, accept removed repositories well and then there are the two errors.

    Regards

    Andreas
    Hi
    Another question, not going through a proxy are you? If so there are some specific changes that are needed.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Re: Upgrade Issue/Registration server invalid system credent

    The firewall is configured as transparent proxy, so if that is enough what changes need to be done?

  6. Re: Upgrade Issue/Registration server invalid system credent

    Quote Originally Posted by astock View Post
    The firewall is configured as transparent proxy, so if that is enough what changes need to be done?
    Hi
    Your proxy should should accept SUSE domain (or at least selected sites used like updates.suse.com and scc.suse.com) without authentication.

    You need to populate proxy setting in YAST and to add two lines with your proxy information to /etc/profile, for example:
    Code:
        export http_proxy="http://10.10.1.1:8081/"
        export https_proxy="https://10.10.1.1:8081/"
    Also add above to /root/.curlrc

    You might need to do some packet captures with say tcpdump or wireshart to see what it's doing (and not doing...).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •