Results 1 to 4 of 4

Thread: SOS8 - Instances not getting DHCP IP

Hybrid View

  1. SOS8 - Instances not getting DHCP IP

    Hi,

    When we deploy instances, the DHCP IP and the attached floating IP is shown in the dashboard, but on the console i observed that the instance is actually getting the DHCP IP. Can anyone please suggest how to solve this issue. As per the documentation, i have created a network, subnet, and router. The router is attached to the external network, and the subnet is plugged to it.



    Thanks & Regards,
    Shashi Kanth.

  2. #2

    Re: SOS8 - Instances not getting DHCP IP

    Quote Originally Posted by shashi_microfocus View Post
    Hi,

    When we deploy instances, the DHCP IP and the attached floating IP is shown in the dashboard, but on the console i observed that the instance is actually getting the DHCP IP. Can anyone please suggest how to solve this issue. As per the documentation, i have created a network, subnet, and router. The router is attached to the external network, and the subnet is plugged to it.



    Thanks & Regards,
    Shashi Kanth.
    Hi,

    this is by design if you choose to launch instances in a self-service network. Without a floating IP those instances wouldn't be able to reach the outside world, and all of the network traffic is handled via network nodes (controller). If you attach a floating IP to the instance, it won't become the internal IP of that instance but is only for NATing via control node and is additionally attached to that instance, that's why you see an additional IP in the dashboard (or CLI), but in fact the instance still has only one internal IP, and that's the one from the DHCP server. Does this clear things up a little?

    Regards,
    Eugen

  3. Re: SOS8 - Instances not getting DHCP IP

    Hi,

    If i run the ifconfig command on the VM console, it is not listing the "internal IP" came from DHCP server, which means the instance is actually not getting the DHCP IP, but the dashboard is displaying it. It seems there is some Neutron DHCP related issue in my environment, and want to know how to solve it.

  4. #4

    Re: SOS8 - Instances not getting DHCP IP

    Oh, you wrote:
    ...but on the console i observed that the instance is actually getting the DHCP IP.
    I assumed everything works as expected, so you say the instance is *NOT* getting an IP? Is DHCP enabled in the base image this instance is based on? Also check neutron dhcp logs for any errors that may occur during instance creation. Usually, the compute nodes also log some neutron related events like

    Code:
    Received unexpected event network-vif-plugged-4a2fc552-98af-41b3-a0a2-d6720e66a053 for instance
    But as a first guess, I would go with the base image and check if DHCP is enabled.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •