Results 1 to 2 of 2

Thread: SLES11 SP4 issues with zypper and SSL certificates

Hybrid View

  1. #1

    SLES11 SP4 issues with zypper and SSL certificates

    Hi all,

    I'm Having issues adding packages in an SLES11 instance that was deployed about a year back (In the AWS Cloud, via the official AMI image for Suse - So Licensing etc is included in my AWS Bill)...

    Code:
    cat /etc/SuSE-release
    SUSE Linux Enterprise Server 11 (x86_64)
    VERSION = 11
    PATCHLEVEL = 4

    When trying to add new Packages I'm just getting "SSL3_GET_SERVER_CERTIFICATE:certificate verify failed" errors...

    Code:
    zypper in aws-cli-1.8.12-20.1.x86_64
    Download (curl) error for 'https://smt-ec2.susecloud.net/repo/$RCE/SLE11-SDK-SP4-Pool/sle-11-x86_64/repodata/repomd.xml?credentials=SMT-http_smt-ec2_susecloud_net':
    Error code: Unrecognized error
    Error message: SSL certificate problem, verify that the CA cert is OK. Details:
    error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

    Anyone have any pointers on how to fix?

  2. #2

    Re: SLES11 SP4 issues with zypper and SSL certificates

    Quote Originally Posted by nedkelly View Post
    Hi all,

    I'm Having issues adding packages in an SLES11 instance that was deployed about a year back (In the AWS Cloud, via the official AMI image for Suse - So Licensing etc is included in my AWS Bill)...

    Code:
    cat /etc/SuSE-release
    SUSE Linux Enterprise Server 11 (x86_64)
    VERSION = 11
    PATCHLEVEL = 4

    When trying to add new Packages I'm just getting "SSL3_GET_SERVER_CERTIFICATE:certificate verify failed" errors...

    Code:
    zypper in aws-cli-1.8.12-20.1.x86_64
    Download (curl) error for 'https://smt-ec2.susecloud.net/repo/$RCE/SLE11-SDK-SP4-Pool/sle-11-x86_64/repodata/repomd.xml?credentials=SMT-http_smt-ec2_susecloud_net':
    Error code: Unrecognized error
    Error message: SSL certificate problem, verify that the CA cert is OK. Details:
    error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

    Anyone have any pointers on how to fix?
    I see you also posted this to the AWS Discussion Forums where it has received attention, including from yourself, so linking here in case it helps others - see https://forums.aws.amazon.com/thread...hreadID=310021

    HTH.
    Simon
    SUSE Knowledge Partner
    ------------------------------------------------------------------------
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below. Thanks.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •