Results 1 to 2 of 2

Thread: Upgrade from SLES 12 SP4 to 15 SP1

  1. Upgrade from SLES 12 SP4 to 15 SP1

    Hi,
    i have a two-node HA-Cluster(pacemaker, corosync) with SLES 12 SP4.
    I'm thinking of upgrading to SLES 15 SP1 because of the more recent pacemaker and corosync Software.
    I'd like to avoid a fresh install because it takes considerable time. On the other hand i always preferred fresh installations and only upgraded from SPx to SPy, but never to a new Major Release. What are your experiences ? Suse itself isn't certain what to do. They recommend to do a fresh installation for a new Major Release, but the Upgrade-Path from 12 SP4 to 15 SP1 is supported. Does anyone tried a Upgrade installation ?

    Thanks.

    Bernd

  2. Re: Upgrade from SLES 12 SP4 to 15 SP1

    Due to the differences in the corosync/pacemaker stack I would recommend a fresh install.
    Theoretically it could work with an upgrade, but as Clusters host critical applications - you never want to deal with unexpected migration side-effects.

    I was thinking about a rolling upgrade - but I'm not sure if the new stack can connect to the old one. Still, you can test that on a test cluster and give feedback.
    Maybe your app is custom and will work without any modification on both SLES 12 & SLES 15. In such case that is also possible (if the old corosync can talk to the new one) and will reduce downtime (just a resource/group failover).

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •