I have finally managed to solve the problem. to do so, I had to execute the following steps:

- abort the graphical installer, in order to fall back to the old "text-graphical" (not the curses based one, that you get when selecting text-based install using F3 in the
isolinux selector).
- Enable ssh and shell by hand in Settings
- Configure the network, (still with no possibility to configure the proxy (in contrary to opensuse at this place). Be sure to select the correct interface, as they are not
usually in the correct alphabetical order.
- The shell is just for nothing, but keep it open until you managed to log as in the next step.
- Log in via ssh and root and password you had to give. If it does not work, you can correct the password or even the network settings in the shell from the previous
step
- Set http_proxy, hitps_proxy and socks_proxy(?) by hand or you can mount your root partition to /mnt, copy over /mnt/etc/sysconf/proxy to /etc/sysconf/proxy and
run . /mnt/etc/profile.d/profile.sh. This also sets your proxy variables. Don't forget to unmount /mnt.
- Finally start the installation by running yast,ssh.

- Does it really have to be so complicated?
- If so, why is there no SuSE-HowTo how to do it? At least I have not found any.
- Is it so uncommon to install/upgrade SLES from behind a mandatory proxy?
- Why can't the graphical installer just get the proxy settings from /etc/sysconfg/proxy from the system to be upgraded?

Hope this helps
Regards, Dieter