Results 1 to 5 of 5

Thread: Issue with repository for SDK

Hybrid View

  1. #1

    Issue with repository for SDK

    I am working on upgrading a SLES 12 SP3 host to SP4 and have run into a problem I can't figure out. When I initially tried 'zypper patch' the process complained that it couldn't access the repsitory index file for 'SUSE_Linux_Enterprise_Server_12_SP3_s390x' and 'SUSE_Linux_Enterprise_Software_Development_Kit_12 _SP3_s390x'. I re-registered the server using 'SUSEConnect -r rec-code -e my-email.com'.

    Now when I run 'zypper patch', it gives
    Code:
    app-wfr23t-830:~ # zypper patch
    Refreshing service 'Legacy_Module_12_s390x'.
    Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP3_s390x'.
    Refreshing service 'SUSE_Linux_Enterprise_Software_Development_Kit_12_SP3_s390x'.
    Problem retrieving the repository index file for service 'SUSE_Linux_Enterprise_Software_Development_Kit_12_SP3_s390x':
    File './repo/repoindex.xml' not found on medium 'https://scc.suse.com/access/services/1414?cookies=0&credentials=SUSE_Linux_Enterprise_Software_Development_Kit_12_SP3_s390x'
    Check if the URI is valid and accessible.
    Building repository 'SLES12-SP3-Pool' cache .....................................................................................................[done]
    Retrieving repository 'SLES12-SP3-Updates' metadata .............................................................................................[done]
    Building repository 'SLES12-SP3-Updates' cache ..................................................................................................[done]
    The server is not behind a proxy. How do I resolve this?


    Harley

  2. #2

    Re: Issue with repository for SDK

    Update:

    I tried to access the SUSE site with
    Code:
    curl https://scc.suse.com/access/services/1414?cookies=0&credentials=SUSE_Linux_Enterprise_Software_Development_Kit_12_SP3_s390x
    It resulted in
    Code:
    [1] 4562
    app-wfr23t-830:~ # {"type":"error","error":"Please provide system/organization credentials.","localized_error":"Please provide system/organization credentials."}^C
    [1]+  Done                    curl https://scc.suse.com/access/services/1414?cookies=0
    What are the credentials that it is looking for? How do I specify them when I run 'zypper patch'?


    Harley

  3. Re: Issue with repository for SDK

    Hi
    So has it added the repositories, can you show the output from;

    Code:
    zypper lr -d
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Re: Issue with repository for SDK

    Hi Malcolm,

    I had checked that yesterday but neglected to post the output. There were 4 respositories for the SDK, with 2 enabled.

    I resolved the issue so I don't think the output from 'zypper lr -d' will be relevant now.

    Prior to SUSConnect there was a process that you needed to follow to re-register a server. The process included navigating to a certain directory, deleting certain files, etc. I thought of this while driving into the office this morning, so I did some more research.

    The issue I had was that the SDK wasn't 'Activated'. The following is the command and output.
    Code:
    app-wfr23t-830:~ # SUSEConnect --list-extensions
    AVAILABLE EXTENSIONS AND MODULES
    
        Advanced Systems Management Module 12 s390x
        Activate with: SUSEConnect -p sle-module-adv-systems-management/12/s390x
    
        Containers Module 12 s390x
        Activate with: SUSEConnect -p sle-module-containers/12/s390x
    
        Legacy Module 12 s390x (Activated)
        Deactivate with: SUSEConnect -d -p sle-module-legacy/12/s390x
    
        Public Cloud Module 12 s390x
        Activate with: SUSEConnect -p sle-module-public-cloud/12/s390x
    
        SUSE Linux Enterprise High Availability Extension 12 SP3 s390x
        Activate with: SUSEConnect -p sle-ha/12.3/s390x -r ADDITIONAL REGCODE
    
            SUSE Linux Enterprise High Availability GEO Extension 12 SP3 s390x
            Activate with: SUSEConnect -p sle-ha-geo/12.3/s390x -r ADDITIONAL REGCODE
    
        SUSE Linux Enterprise Server LTSS 12 SP3 s390x
        Activate with: SUSEConnect -p SLES-LTSS/12.3/s390x -r ADDITIONAL REGCODE
    
        SUSE Linux Enterprise Software Development Kit 12 SP3 s390x
        Activate with: SUSEConnect -p sle-sdk/12.3/s390x
    
        SUSE Manager Server 3.0 s390x
        Activate with: SUSEConnect -p SUSE-Manager-Server/3.0/s390x -r ADDITIONAL REGCODE
    
        SUSE Manager Server 3.1 s390x
        Activate with: SUSEConnect -p SUSE-Manager-Server/3.1/s390x -r ADDITIONAL REGCODE
    
        SUSE Manager Server 3.2 s390x
        Activate with: SUSEConnect -p SUSE-Manager-Server/3.2/s390x -r ADDITIONAL REGCODE
    
        SUSE Package Hub 12 SP3 s390x
        Activate with: SUSEConnect -p PackageHub/12.3/s390x
    
        Toolchain Module 12 s390x
        Activate with: SUSEConnect -p sle-module-toolchain/12/s390x
    
        Web and Scripting Module 12 s390x
        Activate with: SUSEConnect -p sle-module-web-scripting/12/s390x
    
    
    REMARKS
    
    (Not available) The module/extension is not enabled on your RMT/SMT
    (Activated)     The module/extension is activated on your system
    
    MORE INFORMATION
    
    You can find more information about available modules here:
    https://www.suse.com/products/server/features/modules.html
    You can see that the entry for "SUSE Linux Enterprise Software Development Kit 12 SP3 s390x" is not immediately following by 'Activated' like the entry for "Legacy Module 12 s390x". The command to activate is right under the Extension name.

    Here is the command and output:
    Code:
    app-wfr23t-830:~ # SUSEConnect -p sle-sdk/12.3/s390x
    Registering system to SUSE Customer Center
    
    Updating system details on https://scc.suse.com ...
    
    Activating sle-sdk 12.3 s390x ...
    -> Adding service to system ...
    -> Installing release package ...
    
    Successfully registered system
    After this the 'zypper patch' command ran successfully.

    I hope that this helps someone else.


    Harley

  5. Re: Issue with repository for SDK

    Quote Originally Posted by x0500hl View Post
    Hi Malcolm,

    I had checked that yesterday but neglected to post the output. There were 4 respositories for the SDK, with 2 enabled.

    I resolved the issue so I don't think the output from 'zypper lr -d' will be relevant now.

    Prior to SUSConnect there was a process that you needed to follow to re-register a server. The process included navigating to a certain directory, deleting certain files, etc. I thought of this while driving into the office this morning, so I did some more research.

    The issue I had was that the SDK wasn't 'Activated'. The following is the command and output.
    Code:
    app-wfr23t-830:~ # SUSEConnect --list-extensions
    AVAILABLE EXTENSIONS AND MODULES
    
        Advanced Systems Management Module 12 s390x
        Activate with: SUSEConnect -p sle-module-adv-systems-management/12/s390x
    
        Containers Module 12 s390x
        Activate with: SUSEConnect -p sle-module-containers/12/s390x
    
        Legacy Module 12 s390x (Activated)
        Deactivate with: SUSEConnect -d -p sle-module-legacy/12/s390x
    
        Public Cloud Module 12 s390x
        Activate with: SUSEConnect -p sle-module-public-cloud/12/s390x
    
        SUSE Linux Enterprise High Availability Extension 12 SP3 s390x
        Activate with: SUSEConnect -p sle-ha/12.3/s390x -r ADDITIONAL REGCODE
    
            SUSE Linux Enterprise High Availability GEO Extension 12 SP3 s390x
            Activate with: SUSEConnect -p sle-ha-geo/12.3/s390x -r ADDITIONAL REGCODE
    
        SUSE Linux Enterprise Server LTSS 12 SP3 s390x
        Activate with: SUSEConnect -p SLES-LTSS/12.3/s390x -r ADDITIONAL REGCODE
    
        SUSE Linux Enterprise Software Development Kit 12 SP3 s390x
        Activate with: SUSEConnect -p sle-sdk/12.3/s390x
    
        SUSE Manager Server 3.0 s390x
        Activate with: SUSEConnect -p SUSE-Manager-Server/3.0/s390x -r ADDITIONAL REGCODE
    
        SUSE Manager Server 3.1 s390x
        Activate with: SUSEConnect -p SUSE-Manager-Server/3.1/s390x -r ADDITIONAL REGCODE
    
        SUSE Manager Server 3.2 s390x
        Activate with: SUSEConnect -p SUSE-Manager-Server/3.2/s390x -r ADDITIONAL REGCODE
    
        SUSE Package Hub 12 SP3 s390x
        Activate with: SUSEConnect -p PackageHub/12.3/s390x
    
        Toolchain Module 12 s390x
        Activate with: SUSEConnect -p sle-module-toolchain/12/s390x
    
        Web and Scripting Module 12 s390x
        Activate with: SUSEConnect -p sle-module-web-scripting/12/s390x
    
    
    REMARKS
    
    (Not available) The module/extension is not enabled on your RMT/SMT
    (Activated)     The module/extension is activated on your system
    
    MORE INFORMATION
    
    You can find more information about available modules here:
    https://www.suse.com/products/server/features/modules.html
    You can see that the entry for "SUSE Linux Enterprise Software Development Kit 12 SP3 s390x" is not immediately following by 'Activated' like the entry for "Legacy Module 12 s390x". The command to activate is right under the Extension name.

    Here is the command and output:
    Code:
    app-wfr23t-830:~ # SUSEConnect -p sle-sdk/12.3/s390x
    Registering system to SUSE Customer Center
    
    Updating system details on https://scc.suse.com ...
    
    Activating sle-sdk 12.3 s390x ...
    -> Adding service to system ...
    -> Installing release package ...
    
    Successfully registered system
    After this the 'zypper patch' command ran successfully.

    I hope that this helps someone else.


    Harley
    Hi
    Yes, that's where I was heading to Thanks for the feedback and good to see you back on track
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •