Results 1 to 2 of 2

Thread: SBD Fencing required / without Block Storage

Threaded View

  1. Re: SBD Fencing required / without Block Storage

    Quote Originally Posted by natachawalther View Post
    Hi there

    I have a Problem with the SBD-Fencing.

    I set up the Cluster without the SBD-Fencing but it seems that I can't add an Apache Server without the SBD-Fencing. I got this error Message, when I used the wizard to add the Apache:


    Failed to apply configuration (rc=1)
    warning: unpack_config: Blind faith: not fencing unseen nodes

    If I understand it right, I have to use SBD-Fencing to add the Apache.
    That leads me to my next Problem. In our company we can only use File Storage (in my cas a NAS) which doesn't seem to work with SBD-Fencing.


    Is there a way to circumvent the SBD-Fencing od at least do it with my File Storage device?
    Actually pacemaker supports lots of fencing mechanism and you need to pick at least 1 (but you coiuld have multiple fencing 'devices').
    For the list of currently available (installed) fencing resources, run:
    Code:
    crm ra list stonith
    To get info for a specific fencing resource:
    Code:
    crm ra info 'stonith:fence_rhevm'
    Once you create your stonith resoource(s) , you need to update a property which the custer uses to know if any fencing mechanism is available:
    Code:
    crm configure property stonith-enabled=true
    As fencing should be executed prior the switch of your resources , you either need to setup fencing and enable it (see previous post) or disable fencing (previous command but with 'false') and have no support for your cluster.
    You need to properly test fencing prior putting the cluster in production:
    Code:
     crm node fence <nodename>
    Even pacemaker mailing list will not help you without fencing.
    Last edited by strahil-nikolov-dxc; 22-Nov-2019 at 06:50.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •