Results 1 to 5 of 5

Thread: SAP S/4 HANA - ERS High Availability Cluster

  1. #1

    Post SAP S/4 HANA - ERS High Availability Cluster

    Hi Folks,

    I did the ERS Cluster configuration SAP S/4 Hana as stated in below link.

    https://documentation.suse.com/sbp/a...E15/index.html

    The HAWK interface shows all the configured resources as green, but on doing manual fencing of the nodes the cluster resources does not move from one node to another.

    Below is the crm config :

    node 1: CHHANA-PRAP1
    node 2: CHHANAERS1 \
    attributes standby=off maintenance=off
    primitive admin-ip IPaddr2 \
    params ip=10.10.119.42 \
    op monitor interval=10 timeout=20 \
    meta target-role=Started maintenance=false
    primitive rsc_fs_S4P_ASCS00 Filesystem \
    params device="10.10.119.45:/usr/sap/S4P/ASCS00" directory="/usr/sap/S4P/ASCS00" fstype=nfs \
    op start timeout=60s interval=0 \
    op stop timeout=60s interval=0 \
    op monitor interval=20s timeout=40s
    primitive rsc_fs_S4P_ERS10 Filesystem \
    params device="10.10.119.45:/usr/sap/S4P/ERS10" directory="/usr/sap/S4P/ERS10" fstype=nfs \
    op start timeout=60s interval=0 \
    op stop timeout=60s interval=0 \
    op monitor interval=20s timeout=40s
    primitive rsc_ip_S4P_ASCS00 IPaddr2 \
    params ip=10.10.119.43 \
    op monitor interval=10s timeout=20s \
    meta target-role=Started maintenance=false
    primitive rsc_ip_S4P_ERS10 IPaddr2 \
    params ip=10.10.119.44 \
    op monitor interval=10s timeout=20s
    primitive rsc_sap_S4P_ASCS00 SAPInstance \
    operations $id=rsc_sap_S4P_ASCS00-operations \
    op monitor interval=11 timeout=60 \
    op_params on_fail=restart \
    params InstanceName=S4P_ASCS00_sapen2as START_PROFILE="/usr/sap/S4P/SYS/profile/S4P_ASCS00_CHHANAAP" AUTOMATIC_RECOVER=false \
    meta resource-stickiness=5000 maintenance=false target-role=Started
    primitive rsc_sap_S4P_ERS10 SAPInstance \
    operations $id=rsc_sap_S4P_ERS10-operations \
    op monitor interval=11 timeout=60 \
    op_params on_fail=restart \
    params InstanceName=S4P_ERS10_sapen2er START_PROFILE="/usr/sap/S4P/SYS/profile/S4P_ERS10_CHHANAERS" AUTOMATIC_RECOVER=false IS_ERS=true
    primitive stonith-sbd stonith:external/sbd \
    params pcmk_delay_max=30s \
    meta maintenance=false
    group grp_S4P_ASCS00 rsc_ip_S4P_ASCS00 rsc_fs_S4P_ASCS00 rsc_sap_S4P_ASCS00 \
    meta resource-stickiness=3000
    group grp_S4P_ERS10 rsc_ip_S4P_ERS10 rsc_fs_S4P_ERS10 rsc_sap_S4P_ERS10
    location cli-ban-admin-ip-on-CHHANAERS1 admin-ip role=Started -inf: CHHANAERS1
    location cli-ban-grp_S4P_ASCS00-on-CHHANAERS1 grp_S4P_ASCS00 role=Started -inf: CHHANAERS1
    location cli-ban-grp_S4P_ERS10-on-CHHANA-PRAP1 grp_S4P_ERS10 role=Started -inf: CHHANA-PRAP1
    location cli-ban-stonith-sbd-on-CHHANAERS1 stonith-sbd role=Started -inf: CHHANAERS1
    location cli-prefer-admin-ip admin-ip role=Started inf: CHHANA-PRAP1
    location cli-prefer-grp_S4P_ASCS00 grp_S4P_ASCS00 role=Started inf: CHHANA-PRAP1
    location cli-prefer-stonith-sbd stonith-sbd role=Started inf: CHHANA-PRAP1
    colocation col_sap_S4P_no_both -5000: grp_S4P_ERS10 grp_S4P_ASCS00
    order ord_sap_S4P_first_start_ascs Optional: rsc_sap_S4P_ASCS00:start rsc_sap_S4P_ERS10:stop symmetrical=false
    property cib-bootstrap-options: \
    have-watchdog=true \
    dc-version="2.0.1+20190417.13d370ca9-3.3.1-2.0.1+20190417.13d370ca9" \
    cluster-infrastructure=corosync \
    cluster-name=hacluster \
    stonith-enabled=true \
    placement-strategy=balanced \
    maintenance-mode=false
    rsc_defaults rsc-options: \
    resource-stickiness=1 \
    migration-threshold=3
    op_defaults op-options: \
    timeout=600 \
    record-pending=true

    Kindly let me know if you find any inconsistencies with the configuration.

  2. Re: SAP S/4 HANA - ERS High Availability Cluster

    Quote Originally Posted by milind_dhoke View Post
    Hi Folks,

    I did the ERS Cluster configuration SAP S/4 Hana as stated in below link.

    https://documentation.suse.com/sbp/a...E15/index.html

    The HAWK interface shows all the configured resources as green, but on doing manual fencing of the nodes the cluster resources does not move from one node to another.

    Below is the crm config :

    node 1: CHHANA-PRAP1
    node 2: CHHANAERS1 \
    attributes standby=off maintenance=off
    primitive admin-ip IPaddr2 \
    params ip=10.10.119.42 \
    op monitor interval=10 timeout=20 \
    meta target-role=Started maintenance=false
    primitive rsc_fs_S4P_ASCS00 Filesystem \
    params device="10.10.119.45:/usr/sap/S4P/ASCS00" directory="/usr/sap/S4P/ASCS00" fstype=nfs \
    op start timeout=60s interval=0 \
    op stop timeout=60s interval=0 \
    op monitor interval=20s timeout=40s
    primitive rsc_fs_S4P_ERS10 Filesystem \
    params device="10.10.119.45:/usr/sap/S4P/ERS10" directory="/usr/sap/S4P/ERS10" fstype=nfs \
    op start timeout=60s interval=0 \
    op stop timeout=60s interval=0 \
    op monitor interval=20s timeout=40s
    primitive rsc_ip_S4P_ASCS00 IPaddr2 \
    params ip=10.10.119.43 \
    op monitor interval=10s timeout=20s \
    meta target-role=Started maintenance=false
    primitive rsc_ip_S4P_ERS10 IPaddr2 \
    params ip=10.10.119.44 \
    op monitor interval=10s timeout=20s
    primitive rsc_sap_S4P_ASCS00 SAPInstance \
    operations $id=rsc_sap_S4P_ASCS00-operations \
    op monitor interval=11 timeout=60 \
    op_params on_fail=restart \
    params InstanceName=S4P_ASCS00_sapen2as START_PROFILE="/usr/sap/S4P/SYS/profile/S4P_ASCS00_CHHANAAP" AUTOMATIC_RECOVER=false \
    meta resource-stickiness=5000 maintenance=false target-role=Started
    primitive rsc_sap_S4P_ERS10 SAPInstance \
    operations $id=rsc_sap_S4P_ERS10-operations \
    op monitor interval=11 timeout=60 \
    op_params on_fail=restart \
    params InstanceName=S4P_ERS10_sapen2er START_PROFILE="/usr/sap/S4P/SYS/profile/S4P_ERS10_CHHANAERS" AUTOMATIC_RECOVER=false IS_ERS=true
    primitive stonith-sbd stonith:external/sbd \
    params pcmk_delay_max=30s \
    meta maintenance=false
    group grp_S4P_ASCS00 rsc_ip_S4P_ASCS00 rsc_fs_S4P_ASCS00 rsc_sap_S4P_ASCS00 \
    meta resource-stickiness=3000
    group grp_S4P_ERS10 rsc_ip_S4P_ERS10 rsc_fs_S4P_ERS10 rsc_sap_S4P_ERS10
    location cli-ban-admin-ip-on-CHHANAERS1 admin-ip role=Started -inf: CHHANAERS1
    location cli-ban-grp_S4P_ASCS00-on-CHHANAERS1 grp_S4P_ASCS00 role=Started -inf: CHHANAERS1
    location cli-ban-grp_S4P_ERS10-on-CHHANA-PRAP1 grp_S4P_ERS10 role=Started -inf: CHHANA-PRAP1
    location cli-ban-stonith-sbd-on-CHHANAERS1 stonith-sbd role=Started -inf: CHHANAERS1
    location cli-prefer-admin-ip admin-ip role=Started inf: CHHANA-PRAP1
    location cli-prefer-grp_S4P_ASCS00 grp_S4P_ASCS00 role=Started inf: CHHANA-PRAP1
    location cli-prefer-stonith-sbd stonith-sbd role=Started inf: CHHANA-PRAP1
    colocation col_sap_S4P_no_both -5000: grp_S4P_ERS10 grp_S4P_ASCS00
    order ord_sap_S4P_first_start_ascs Optional: rsc_sap_S4P_ASCS00:start rsc_sap_S4P_ERS10:stop symmetrical=false
    property cib-bootstrap-options: \
    have-watchdog=true \
    dc-version="2.0.1+20190417.13d370ca9-3.3.1-2.0.1+20190417.13d370ca9" \
    cluster-infrastructure=corosync \
    cluster-name=hacluster \
    stonith-enabled=true \
    placement-strategy=balanced \
    maintenance-mode=false
    rsc_defaults rsc-options: \
    resource-stickiness=1 \
    migration-threshold=3
    op_defaults op-options: \
    timeout=600 \
    record-pending=true

    Kindly let me know if you find any inconsistencies with the configuration.
    Looks like you have left some manual migration constraints in the cluster configuration.
    All of these cli* constraints should be removed /deleted from the cib.

    You may use "crm configure edit" or HAWK to remove these constraints. They were all put there by manually moving or migrating resources.

    location cli-ban-admin-ip-on-CHHANAERS1 admin-ip role=Started -inf: CHHANAERS1
    location cli-ban-grp_S4P_ASCS00-on-CHHANAERS1 grp_S4P_ASCS00 role=Started -inf: CHHANAERS1
    location cli-ban-grp_S4P_ERS10-on-CHHANA-PRAP1 grp_S4P_ERS10 role=Started -inf: CHHANA-PRAP1
    location cli-ban-stonith-sbd-on-CHHANAERS1 stonith-sbd role=Started -inf: CHHANAERS1
    location cli-prefer-admin-ip admin-ip role=Started inf: CHHANA-PRAP1
    location cli-prefer-grp_S4P_ASCS00 grp_S4P_ASCS00 role=Started inf: CHHANA-PRAP1
    location cli-prefer-stonith-sbd stonith-sbd role=Started inf: CHHANA-PRAP1

  3. #3

    Re: SAP S/4 HANA - ERS High Availability Cluster

    Hi

    Please check your setting for quorum policy
    If not set to ignore and you only run 2 nodes, it will not be acivated on the remaining node

    crm configure property no-quorum-policy=ignore

  4. Re: SAP S/4 HANA - ERS High Availability Cluster

    Quote Originally Posted by milind_dhoke View Post
    Hi Folks,

    I did the ERS Cluster configuration SAP S/4 Hana as stated in below link.

    https://documentation.suse.com/sbp/a...E15/index.html

    The HAWK interface shows all the configured resources as green, but on doing manual fencing of the nodes the cluster resources does not move from one node to another.

    Below is the crm config :

    node 1: CHHANA-PRAP1
    node 2: CHHANAERS1 \
    attributes standby=off maintenance=off
    primitive admin-ip IPaddr2 \
    params ip=10.10.119.42 \
    op monitor interval=10 timeout=20 \
    meta target-role=Started maintenance=false
    primitive rsc_fs_S4P_ASCS00 Filesystem \
    params device="10.10.119.45:/usr/sap/S4P/ASCS00" directory="/usr/sap/S4P/ASCS00" fstype=nfs \
    op start timeout=60s interval=0 \
    op stop timeout=60s interval=0 \
    op monitor interval=20s timeout=40s
    primitive rsc_fs_S4P_ERS10 Filesystem \
    params device="10.10.119.45:/usr/sap/S4P/ERS10" directory="/usr/sap/S4P/ERS10" fstype=nfs \
    op start timeout=60s interval=0 \
    op stop timeout=60s interval=0 \
    op monitor interval=20s timeout=40s
    primitive rsc_ip_S4P_ASCS00 IPaddr2 \
    params ip=10.10.119.43 \
    op monitor interval=10s timeout=20s \
    meta target-role=Started maintenance=false
    primitive rsc_ip_S4P_ERS10 IPaddr2 \
    params ip=10.10.119.44 \
    op monitor interval=10s timeout=20s
    primitive rsc_sap_S4P_ASCS00 SAPInstance \
    operations $id=rsc_sap_S4P_ASCS00-operations \
    op monitor interval=11 timeout=60 \
    op_params on_fail=restart \
    params InstanceName=S4P_ASCS00_sapen2as START_PROFILE="/usr/sap/S4P/SYS/profile/S4P_ASCS00_CHHANAAP" AUTOMATIC_RECOVER=false \
    meta resource-stickiness=5000 maintenance=false target-role=Started
    primitive rsc_sap_S4P_ERS10 SAPInstance \
    operations $id=rsc_sap_S4P_ERS10-operations \
    op monitor interval=11 timeout=60 \
    op_params on_fail=restart \
    params InstanceName=S4P_ERS10_sapen2er START_PROFILE="/usr/sap/S4P/SYS/profile/S4P_ERS10_CHHANAERS" AUTOMATIC_RECOVER=false IS_ERS=true
    primitive stonith-sbd stonith:external/sbd \
    params pcmk_delay_max=30s \
    meta maintenance=false
    group grp_S4P_ASCS00 rsc_ip_S4P_ASCS00 rsc_fs_S4P_ASCS00 rsc_sap_S4P_ASCS00 \
    meta resource-stickiness=3000
    group grp_S4P_ERS10 rsc_ip_S4P_ERS10 rsc_fs_S4P_ERS10 rsc_sap_S4P_ERS10
    location cli-ban-admin-ip-on-CHHANAERS1 admin-ip role=Started -inf: CHHANAERS1
    location cli-ban-grp_S4P_ASCS00-on-CHHANAERS1 grp_S4P_ASCS00 role=Started -inf: CHHANAERS1
    location cli-ban-grp_S4P_ERS10-on-CHHANA-PRAP1 grp_S4P_ERS10 role=Started -inf: CHHANA-PRAP1
    location cli-ban-stonith-sbd-on-CHHANAERS1 stonith-sbd role=Started -inf: CHHANAERS1
    location cli-prefer-admin-ip admin-ip role=Started inf: CHHANA-PRAP1
    location cli-prefer-grp_S4P_ASCS00 grp_S4P_ASCS00 role=Started inf: CHHANA-PRAP1
    location cli-prefer-stonith-sbd stonith-sbd role=Started inf: CHHANA-PRAP1
    colocation col_sap_S4P_no_both -5000: grp_S4P_ERS10 grp_S4P_ASCS00
    order ord_sap_S4P_first_start_ascs Optional: rsc_sap_S4P_ASCS00:start rsc_sap_S4P_ERS10:stop symmetrical=false
    property cib-bootstrap-options: \
    have-watchdog=true \
    dc-version="2.0.1+20190417.13d370ca9-3.3.1-2.0.1+20190417.13d370ca9" \
    cluster-infrastructure=corosync \
    cluster-name=hacluster \
    stonith-enabled=true \
    placement-strategy=balanced \
    maintenance-mode=false
    rsc_defaults rsc-options: \
    resource-stickiness=1 \
    migration-threshold=3
    op_defaults op-options: \
    timeout=600 \
    record-pending=true

    Kindly let me know if you find any inconsistencies with the configuration.
    You have too many location constraints caused by migrations (you can identify them by 'cli-ban' and 'cli-prefer').
    Just run 'crm resource unmigrate <TARGET>' where TARGET is every resource inthe group and each group in the cluster.

    This is a 'rookie' mistake to people new to openais & corosync/pacemaker stacks.

  5. Re: SAP S/4 HANA - ERS High Availability Cluster

    Quote Originally Posted by sandergemert View Post
    Hi

    Please check your setting for quorum policy
    If not set to ignore and you only run 2 nodes, it will not be acivated on the remaining node

    crm configure property no-quorum-policy=ignore
    In recent versions this is a bad recommendation.
    ha-cluster-init properly sets the 'two_node= true' flag on each member of the cluster which sets the quorum to be artificially set to '1' .

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •