This is a self made issue. Jumbo frames don't bring any performance gain with a good network card. Good network card has enough hardware acceleration on board (offloading). Check:
Code:
# ethtool --show-offload eth0
Switch off jumbo frames and tune your network settings:
https://fasterdata.es.net/host-tunin...x/100g-tuning/