I have a colleague working on an install of Orbeon Forms using SLES 15.1 and we ran into an oddity with the default Tomcat install.

This declaration is in the default /etc/tomcat/tomcat.conf:

Code:
JAVA_OPTS="-Djavax.sql.DataSource.Factory=org.apache.commons.dbcp.BasicDataSourceFactory"
However, by default, the dbcp installed is version 2, even though the package is named apache-commons-dbcp when installing. There is a apache-commons-dbcp1 package that can be installed, but it is not installed by default.

I am wondering if this is a packaging error that needs to be corrected, or something else. Thanks!