Hi, Malcolm! Thank you very much for your most kind and helpful response to my posting. I apologise for the delay in reverting. This reply would have reached you yesterday, but for the fact that I had a menacing system freeze just moments before I was due to post on this forum. I had no choice but to reboot and, thus, lose everything I had composed. This time, however, I have taken the precaution of composing on LibreOffice Writer and then pasting the text directly into the forum.

Anyway, and as requested by your good self, I append below the information sought for the following packages: libavfilter6, libswscale4, libavdevice57, libavutil55 and libavresample3:-

Code:
chris@Esprimo-1:~> zypper if libavfilter6
Loading repository data...
Reading installed packages...

Information for package libavfilter6:
--------------------------------------------------
Repository    :   SLE-Module-Packagehub-Subpackages15-SP1-Pool
Name    :   libavfilter6 
Version    :   3.4.2-4.12.4 
Arch    :   x86_64 
Vendor    :   SUSE LLC <https://www.suse.com/> 
Support Level    :   unsupported 
Installed Size    :   2.4 MiB 
Installed    :   Yes 
Status    :   up-to-date 
Source package    :   ffmpeg-3.4.2-4.12.4.src 
Summary    :   FFmpeg audio and video filtering library 


Information for package libswscale4:
-----------------------------------------------------
Repository    :   SLE-Module-Desktop-Applications15-SP1-Updates 
Name    :   libswscale4 
Version    :   3.4.2-4.27.1 
Arch    :   x86_64 
Vendor    :   SUSE LLC <https://www.suse.com/> 
Support Level    :   Level 3 
Installed Size    :   502.4 KiB 
Installed    :   Yes 
Status    :   out-of-date (version 3.4.2-4.12.4 installed) 
Source package    :   ffmpeg-3.4.2-4.27.1.src 
Summary    :   FFmpeg image scaling and colorspace/pixel conversion library


Information for package libavdevice57:
--------------------------------------------------------
Repository    :   SLE-Module-Packagehub-Subpackages15-SP1-Pool
Name    :   libavdevice57 
Version    :   3.4.2-4.12.4 
Arch    :   x86_64 
Vendor    :   SUSE LLC <https://www.suse.com/> 
Support Level    :   unsupported 
Installed Size    :   127.8 KiB 
Installed    :   Yes 
Status    :   up-to-date 
Source package    :   ffmpeg-3.4.2-4.12.4.src 
Summary    :   FFmpeg device library


Information for package libavutil55:
---------------------------------------------------
Repository    :   SLE-Module-Desktop-Applications15-SP1-Updates
Name    :   libavutil55 
Version    :   3.4.2-4.27.1 
Arch    :   x86_64 
Vendor    :   SUSE LLC <https://www.suse.com/> 
Support Level    :   Level 3 
Installed Size    :   411.0 KiB 
Installed    :   Yes 
Status    :   out-of-date (version 3.4.2-4.12.4 installed) 
Source package    :   ffmpeg-3.4.2-4.27.1.src 
Summary    :   FFmpeg's utility library 


Information for package libavresample3:
----------------------------------------------------------
Repository    :   SLE-Product-WE15-SP1-Updates 
Name    :   libavresample3 
Version    :   3.4.2-4.27.1 
Arch    :   x86_64 
Vendor    :   SUSE LLC <https://www.suse.com/> 
Support Level    :   Level 2 
Installed Size    :   126.4 KiB 
Installed    :   Yes 
Status    :   out-of-date (version 3.4.2-4.12.4 installed)
Source package    :   ffmpeg-3.4.2-4.27.1.src 
Summary    :   FFmpeg alternate audio resampling library
You have asked whether ffmpeg is installed. No, a YaST2 search reveals it is NOT installed presently, but version 3.4.2-4.12.4 is available via YaST. SUSE PackageHub’s version is much outdated, with only version 12 offered.

Malcolm, I await with keen interest your further kind advice, in hope a forced rebuild of the cache may yet prove to be unnecessary. Cheers!

MagnifiKat
(aka. SpringPuss)