Hi folks,

I have a Xen VM that initially was running Windows 2003 (32-bit O/S). I installed the Xen Driver Pack and confirmed proper functionality with the VM. Later, the VM was upgraded to Windows 2008 (32-bit O/S). The upgrade completed successfully, but the Xen Driver Pack was impacted by the installation. I've tried to upgrade the Driver Pack using the standard installation approach, but was told that I need to uninstall the previous Driver Pack set (for Windows 2003). Using the uninstall.exe listed in the Progam Files subdirectory, Windows 2008 tells me it can't run the application because it doesn't match the version of the current O/S. I tried to use the "/force" parameter, but installer enforces the point that I need to uninstall the previous version. I finally tried copying the uninstall.exe from the Windows 2008 x86 directory into the program Files subdirectory, and that seemed to do the trick as to uninstalling the drivers.

I then tried installing the driver pack from the Windows 2008 area. The installation completed and prompted me to reboot the VM. I rebooted and checked the drivers of the VM. The drivers are there, but the device manager does not recognize them as being installed.

Any thoughts?

Elliott