The goal was to configure the automouter. But when I tried to start the autofs service I received an error:

Code:
fcbxen11:/etc/init.d # rcautofs start
Starting automount Error: failed to load autofs4 module.
So I tried to load the module manually

Code:
fcbxen11:/etc/init.d # modprobe autofs4
FATAL: Could not load /lib/modules/2.6.40-0.27-xen/modules.dep: No such file or directory
fcbxen11:/etc/init.d # ls -l /lib/modules/
total 4
drwxr-xr-x 4 root root 4096 Aug  7 23:01 3.0.13-0.27-xen

As the next step I checked the uname output

Code:
fcbxen11:/etc/init.d # uname -a
Linux fcbxen11 2.6.40-0.27-xen #1 SMP Wed Feb 15 13:33:49 UTC 2012 (d73692b) x86_64 x86_64 x86_64 GNU/Linux
But my system is running with an 3.0 Kernel so why does uname report the wrong kernel version? The correct Version is:

Code:
fcbxen11:/etc/init.d # cat /proc/version
Linux version 3.0.13-0.27-xen (geeko@buildhost) (gcc version 4.3.4 [gcc-4_3-branch revision 152973] (SUSE Linux) ) #1 SMP Wed Feb 15 13:33:49 UTC 2012 (d73692b)
Is this a feature like uname26 to mask the kernel 3.0? But I haven't activated such a feature and I'm using the same dd image with another XEN guest which is reporting the correct kernel version.