Quote Originally Posted by KBOYLE View Post
When you run "/usr/sbin/wagon &" it checks your registration and adds the required repositories to your system before beginning the upgrade. In the table below, the "bold" repositories (with "SP2") were added by wagon to my SLED11 system before beginning the upgrade. The red repositories were not shown in the list of repositories on your system. Without those repositories, YaST will not find any of the packages it needs for the upgrade.

Code:
#  | Alias                                               | Name                                              | Enabled | Refresh
---+-----------------------------------------------------+---------------------------------------------------+---------+--------
1  | ATI-Driver-SLE11-SP1                                | ATI-Driver-SLE11-SP1                              | Yes     | Yes    
2  | ATI-Driver-SLE11-SP2                                | ATI-Driver-SLE11-SP2                              | Yes     | Yes    
3  | Novell_NTS_-_Supportconfig                          | Novell NTS - Supportconfig                        | Yes     | Yes    
4  | SUSE-Linux-Enterprise-Desktop-11-SP1_11.1.1-1.133_1 | SUSE-Linux-Enterprise-Desktop-11-SP1 11.1.1-1.133 | Yes     | Yes    
5  | nVidia-Driver-SLE11-SP1                             | nVidia-Driver-SLE11-SP1                           | Yes     | Yes    
6  | nVidia-Driver-SLE11-SP2                             | nVidia-Driver-SLE11-SP2                           | Yes     | Yes    
7  | nu_novell_com:SLE11-SP1-Debuginfo-Pool              | SLE11-SP1-Debuginfo-Pool                          | No      | Yes    
8  | nu_novell_com:SLE11-SP1-Debuginfo-Updates           | SLE11-SP1-Debuginfo-Updates                       | No      | Yes    
9  | nu_novell_com:SLE11-SP2-Debuginfo-Core              | SLE11-SP2-Debuginfo-Core                          | No      | Yes    
10 | nu_novell_com:SLE11-SP2-Debuginfo-Updates           | SLE11-SP2-Debuginfo-Updates                       | No      | Yes    
11 | nu_novell_com:SLED11-Extras                         | SLED11-Extras                                     | No      | Yes    
12 | nu_novell_com:SLED11-SP1-Pool                       | SLED11-SP1-Pool                                   | Yes     | Yes    
13 | nu_novell_com:SLED11-SP1-Updates                    | SLED11-SP1-Updates                                | Yes     | Yes    
14 | nu_novell_com:SLED11-SP2-Core                       | SLED11-SP2-Core                                   | Yes     | Yes    
15 | nu_novell_com:SLED11-SP2-Updates                    | SLED11-SP2-Updates                                | Yes     | Yes
I don't know why those two repositories are missing. You may find something in /var/log/YaST2/y2log.

Where to go from here? Well you can try again following TID 7010200: How to upgrade to SLES/SLED 11 SP2.
  • Apply online updates.
  • Run wagon.
  • After the Customer Center configuration, but before continuing with the upgrade, check to see if the missing repositories are present:
  • Code:
    zypper lr
  • If they are, continue with the upgrade. If they are not you may have to upgrade from the DVD.


If anyone else has any ideas, please feel free to jump in!
About the Online Update, I mentioned earlier that I cannot update two patches, maybe that's what's been causing the problem:

Code:
nothing provides hal = 0.5.12-23.58.22 needed by hal-devel-0.5.12-23.58.22.i586
Options:
  • Following actions will be done: deinstallation of hal-devel-0.5.12-23.49.51.1.i586 deinstallation of gnome-vfs2-devel-2.24.2-2.6.1.i586 deinstallation of libgsf-devel-1.14.9-2.27.i586 deinstallation of librsvg-devel-2.26.0-2.3.1.i586
  • do not install patch: sdksp2-hal-6332.noarch
  • break hal-devel by ignoring some of its dependencies
evolution-pilot-2.28.2-0.21.1.i586 requires evolution = 2.28.2-0.21.1, but this requirement cannot be provided) Options:
  • deinstallation of evolution-pilot-2.28.2-0.21.1.i586
  • do not install patch sdksp2-evolution-201207-6611.noarch
  • break evolution-pilot by ignoring some of its dependencies
I'm really not sure what to do with them.