Quote Originally Posted by PauliusC View Post
About the Online Update, I mentioned earlier that I cannot update two patches, maybe that's what's been causing the problem:

I'm really not sure what to do with them.
Do you now have your missing repositories?

In your previous post you show these repositories:
  • nu_novell_com:SLE11-SDK-SP2-Core
  • nu_novell_com:SLE11-SDK-SP2-Updates

But you are missing these repositories:
  • nu_novell_com:SLED11-SP2-Core
  • nu_novell_com:SLED11-SP2-Updates


Patch sdksp2-hal-6332.noarch is an SP2 patch but it can't find dependent packages probably because those SLED11-SP2 repositories are missing.

It appears that wagon did not setup all the necessary repositories before beginning the upgrade. As I see it, you have a few choices:
  • You can attempt the upgrade using the DVD.
  • You can try to find out what went wrong with the wagon online upgrade:
    • If the missing repositories are created when you run wagon again, you may be able to complete the online upgrade.
    • If you are still unable to complete an online upgrade, you can open a Service Request for additional assistance. There may be a bug preventing the upgrade. Tech Support can help identify the issue and find a solution.


Once you have installed all the SP2 packages, you should no longer have dependency issues with patches for the SDK.