Results 1 to 10 of 10

Thread: Failed to upgrade to SLED 11 SP2?

  1. #1

    Failed to upgrade to SLED 11 SP2?

    Hello all.
    I tried to upgrade my system (SLED 11 SP1) to SP2, following these steps > http://www.novell.com/support/kb/doc.php?id=7010200 using YaST. I completed it and got the message that the system should be on SP2 level after reboot. However, after reboot, The green boot screen still shows SP1. Also:

    $ cat SuSE-release
    SUSE Linux Enterprise Desktop 11 (i586)
    VERSION = 11
    PATCHLEVEL = 1

    I'm really not sure where the problem is. I'm actually quite a novice on linux.

  2. #2

    Re: Failed to upgrade to SLED 11 SP2?

    PauliusC wrote:

    >
    > Hello all.
    > I tried to upgrade my system (SLED 11 SP1) to SP2, following these
    > steps > http://www.novell.com/support/kb/doc.php?id=7010200 using
    > YaST.


    You haven't provided many details. A little more information would help.

    When you said you used YaST. Was that
    1) YaST ("yast2 wagon")? or
    2) the Online-Update module (YOU)?

    I experienced a similar issue when I used wagon to upgrade to SP2. I
    had cerated a local installation source using the SP2 media much like I
    had done when upgrading to new versions of SLES10. As it turns out,
    wagon gets totally confused if it finds a SLES11-SP2 installation
    source and completes the install without installing anything.

    I don't know what happened in your case, but that is one way to
    complete an upgrade without accomplishing anything. ;-)

    --
    Kevin Boyle - Knowledge Partner
    If you find this post helpful and are using the web interface,
    show your appreciation and click on the star below...

  3. #3

    Re: Failed to upgrade to SLED 11 SP2?

    Quote Originally Posted by KBOYLE View Post
    PauliusC wrote:

    >
    > Hello all.
    > I tried to upgrade my system (SLED 11 SP1) to SP2, following these
    > steps > http://www.novell.com/support/kb/doc.php?id=7010200 using
    > YaST.


    You haven't provided many details. A little more information would help.

    When you said you used YaST. Was that
    1) YaST ("yast2 wagon")? or
    2) the Online-Update module (YOU)?

    I experienced a similar issue when I used wagon to upgrade to SP2. I
    had cerated a local installation source using the SP2 media much like I
    had done when upgrading to new versions of SLES10. As it turns out,
    wagon gets totally confused if it finds a SLES11-SP2 installation
    source and completes the install without installing anything.

    I don't know what happened in your case, but that is one way to
    complete an upgrade without accomplishing anything. ;-)

    --
    Kevin Boyle - Knowledge Partner
    If you find this post helpful and are using the web interface,
    show your appreciation and click on the star below...
    Well, according to that documentation, there are basically two ways to upgrade: using Online-Update + Yast or downloadable media. I used the first one.

  4. #4

    Re: Failed to upgrade to SLED 11 SP2?

    PauliusC wrote:

    > Well, according to that documentation, there are basically two ways to
    > upgrade: using Online-Update + Yast or downloadable media. I used the
    > first one.


    Okay, but within the first one, there are also two choices:

    > For installing SP2 via the respective patches, the following tools
    > are supported:
    >
    > 1) YaST ("yast2 wagon")
    > 2) zypper


    When things go wrong, it is often because some small thing was
    overlooked. If you want to find out what that might be, we have to be
    very specific about what you did or did not do and review the whole
    process.

    So, lets start with the document:

    TID 7010200: How to upgrade to SLES/SLED 11 SP2
    http://www.novell.com/support/kb/doc.php?id=7010200

    > SLES/SLED 11 Service Pack 2 is a full product; a variety of methods
    > for updating a system exist.


    If you would rather not go through the whole process again, then:
    > Alternatively, the full SP2 media (DVD ISO image) can be downloaded
    > and one of the following procedures can be used, especially in case
    > of environments without network access:
    >
    > 3) by booting from SLES/SLED 11 SP2 media

    When online upgrades fail, that is a pretty reliable way to complete
    the upgrade.


    > Update to SP2 via patches
    > Attention: The update process has to be done completely from
    > beginning to reboot. There is only a limited chance to revert
    > changes. Furthermore, the server has to be connected online during
    > the whole update process. Prerequisites: Users have to make sure to
    > have the system registered. If this is not done already, it can
    > either be registered by using the "Novell Customer Center
    > Configuration" module in YaST or by using the suse_register
    > commandline tool. This will add update sources to the system.


    The first thing to verify: Is your system registered? If it isn't. you
    won't get the updates.

    Did you try to do a minimal or full migration?

    Depending where/why the upgrade failed, it may not be possible to
    complete it using the patch method in which case your only option would
    be by booting from SLES/SLED 11 SP2 media.





    --
    Kevin Boyle - Knowledge Partner
    If you find this post helpful and are using the web interface,
    show your appreciation and click on the star below...

  5. #5

    Re: Failed to upgrade to SLED 11 SP2?

    Quote Originally Posted by KBOYLE View Post
    PauliusC wrote:

    > Well, according to that documentation, there are basically two ways to
    > upgrade: using Online-Update + Yast or downloadable media. I used the
    > first one.


    Okay, but within the first one, there are also two choices:

    > For installing SP2 via the respective patches, the following tools
    > are supported:
    >
    > 1) YaST ("yast2 wagon")
    > 2) zypper


    When things go wrong, it is often because some small thing was
    overlooked. If you want to find out what that might be, we have to be
    very specific about what you did or did not do and review the whole
    process.

    So, lets start with the document:

    TID 7010200: How to upgrade to SLES/SLED 11 SP2
    http://www.novell.com/support/kb/doc.php?id=7010200

    > SLES/SLED 11 Service Pack 2 is a full product; a variety of methods
    > for updating a system exist.


    If you would rather not go through the whole process again, then:
    > Alternatively, the full SP2 media (DVD ISO image) can be downloaded
    > and one of the following procedures can be used, especially in case
    > of environments without network access:
    >
    > 3) by booting from SLES/SLED 11 SP2 media

    When online upgrades fail, that is a pretty reliable way to complete
    the upgrade.


    > Update to SP2 via patches
    > Attention: The update process has to be done completely from
    > beginning to reboot. There is only a limited chance to revert
    > changes. Furthermore, the server has to be connected online during
    > the whole update process. Prerequisites: Users have to make sure to
    > have the system registered. If this is not done already, it can
    > either be registered by using the "Novell Customer Center
    > Configuration" module in YaST or by using the suse_register
    > commandline tool. This will add update sources to the system.


    The first thing to verify: Is your system registered? If it isn't. you
    won't get the updates.

    Did you try to do a minimal or full migration?

    Depending where/why the upgrade failed, it may not be possible to
    complete it using the patch method in which case your only option would
    be by booting from SLES/SLED 11 SP2 media.





    --
    Kevin Boyle - Knowledge Partner
    If you find this post helpful and are using the web interface,
    show your appreciation and click on the star below...
    I used YaST wagon for install (the GUI option) and I tried to do the full migration.
    As for the registration, I THINK that my system is registered properly, but I'm not really sure how I should verify it.

    Moreover, I think it was said somewhere that all the updates had to be installed. However, there are 2 updates now, which I cannot install properly: update for hal and update for evolution. Maybe that could be the cause. (I get the following error: nothing provides hal = 0.5.12-23.58.22 needed by hal-devel-0.5.12-23.58.22.i586
    evolution-pilot-2.28.2-0.21.1.i586 requires evolution = 2.28.2-0.21.1, but this requirement cannot be provided).

    I guess there is no choice but to use the DVD then.

    Thanks.

  6. #6

    Re: Failed to upgrade to SLED 11 SP2?

    PauliusC wrote:

    > I used YaST wagon for install (the GUI option) and I tried to do the
    > full migration.
    > As for the registration, I THINK that my system is registered
    > properly, but I'm not really sure how I should verify it.


    YaST wagon gets all the updates online. If your system is *not*
    properly registered, you will *not* have access to the updates.

    Check the status of your system in the Novell Customer Center:
    https://secure-www.novell.com/center...s/home_app.jsp

    One of the first things wagon does to your system is to setup the
    correct repositories for the SP2 updates. If your system is properly
    registered you will have access to the needed repositories.

    Please post the output from:
    Code:
    zypper lr
    It will be easier to read if your terminal screen is extra wide when
    you run the command and if you post using "code tags". (Click on the
    "Go Advanced" button then use the "#" from the tool bar, then insert
    your text between the tags.)

    > I guess there is no choice but to use the DVD then.

    Not necessarily but it is always an option.

    --
    Kevin Boyle - Knowledge Partner
    If you find this post helpful and are using the web interface,
    show your appreciation and click on the star below...

  7. #7

    Re: Failed to upgrade to SLED 11 SP2?

    Quote Originally Posted by KBOYLE View Post
    PauliusC wrote:

    > I used YaST wagon for install (the GUI option) and I tried to do the
    > full migration.
    > As for the registration, I THINK that my system is registered
    > properly, but I'm not really sure how I should verify it.


    YaST wagon gets all the updates online. If your system is *not*
    properly registered, you will *not* have access to the updates.

    Check the status of your system in the Novell Customer Center:
    https://secure-www.novell.com/center...s/home_app.jsp

    One of the first things wagon does to your system is to setup the
    correct repositories for the SP2 updates. If your system is properly
    registered you will have access to the needed repositories.

    Please post the output from:
    Code:
    zypper lr
    It will be easier to read if your terminal screen is extra wide when
    you run the command and if you post using "code tags". (Click on the
    "Go Advanced" button then use the "#" from the tool bar, then insert
    your text between the tags.)

    > I guess there is no choice but to use the DVD then.

    Not necessarily but it is always an option.

    --
    Kevin Boyle - Knowledge Partner
    If you find this post helpful and are using the web interface,
    show your appreciation and click on the star below...

    Actually, I was not really sure, where at the Novell Customer Center it shows that my system is registered/unregistered, so I used Novell Customer Center Configuration, and it seems that it has completed successfully (although no repositories needed to be changed).

    The output of zypper lr:

    Code:
    #  | Alias                                                             | Name                                                  | Enabled | Refresh
    ---+-------------------------------------------------------------------+-------------------------------------------------------+---------+--------
    1  | ATI-Driver-HP-BNB-SLE11-SP1                                       | ATI-Driver-HP-BNB-SLE11-SP1                           | Yes     | Yes    
    2  | ATI-Driver-HP-BNB-SLE11-SP2                                       | ATI-Driver-HP-BNB-SLE11-SP2                           | Yes     | Yes    
    3  | Broadcom-Driver-HP-BNB-SLE11-SP1                                  | Broadcom-Driver-HP-BNB-SLE11-SP1                      | Yes     | Yes    
    4  | Broadcom-Driver-HP-BNB-SLE11-SP2                                  | Broadcom-Driver-HP-BNB-SLE11-SP2                      | Yes     | Yes    
    5  | HP-BNB-Dedicated-Update-Channel                                   | HP-BNB-Dedicated-Update-Channel                       | Yes     | Yes    
    6  | LSI-Driver-HP-BNB-SLE11-SP2                                       | LSI-Driver-HP-BNB-SLE11-SP2                           | Yes     | Yes    
    7  | OBS-Wine                                                          | OBS-Wine                                              | Yes     | No     
    8  | Repository                                                        | SUSE Linux Enterprise Software Development Kit 11 SP1 | Yes     | No     
    9  | Repository_1                                                      | SUSE Linux Enterprise Software Development Kit 11 SP1 | Yes     | No     
    10 | SUSE-Linux-Enterprise-Hardware-Refresh-2011A-11-SP1_11.1.1-1.2    | SUSE Linux Enterprise Hardware Refresh 2011A 11 SP1   | Yes     | No     
    11 | SUSE-Linux-Enterprise-Software-Development-Kit-11-SP1_11.1.1-1.57 | SUSE Linux Enterprise Software Development Kit 11 SP1 | Yes     | No     
    12 | VALIDITYINC-Driver-HP-BNB-SLE11-SP2                               | VALIDITYINC-Driver-HP-BNB-SLE11-SP2                   | Yes     | Yes    
    13 | nVidia-Driver-SLE11-SP1                                           | nVidia-Driver-SLE11-SP1                               | Yes     | Yes    
    14 | nu_novell_com:SLE11-SDK-SP1-Pool                                  | SLE11-SDK-SP1-Pool                                    | Yes     | Yes    
    15 | nu_novell_com:SLE11-SDK-SP1-Updates                               | SLE11-SDK-SP1-Updates                                 | Yes     | Yes    
    16 | nu_novell_com:SLE11-SDK-SP2-Core                                  | SLE11-SDK-SP2-Core                                    | Yes     | Yes    
    17 | nu_novell_com:SLE11-SDK-SP2-Updates                               | SLE11-SDK-SP2-Updates                                 | Yes     | Yes    
    18 | nu_novell_com:SLE11-SP1-Debuginfo-Pool                            | SLE11-SP1-Debuginfo-Pool                              | No      | Yes    
    19 | nu_novell_com:SLE11-SP1-Debuginfo-Updates                         | SLE11-SP1-Debuginfo-Updates                           | No      | Yes    
    20 | nu_novell_com:SLED11-Extras                                       | SLED11-Extras                                         | No      | Yes    
    21 | nu_novell_com:SLED11-SP1-HP-BNB-Updates                           | SLED11-SP1-HP-BNB-Updates                             | Yes     | Yes    
    22 | nu_novell_com:SLED11-SP1-Pool                                     | SLED11-SP1-Pool                                       | Yes     | Yes    
    23 | nu_novell_com:SLED11-SP1-Updates                                  | SLED11-SP1-Updates                                    | Yes     | Yes    
    24 | security                                                          | security                                              | Yes     | Yes

  8. #8

    Re: Failed to upgrade to SLED 11 SP2?

    Quote Originally Posted by PauliusC View Post
    I used Novell Customer Center Configuration, and it seems that it has completed successfully (although no repositories needed to be changed).
    When you run "/usr/sbin/wagon &" it checks your registration and adds the required repositories to your system before beginning the upgrade. In the table below, the "bold" repositories (with "SP2") were added by wagon to my SLED11 system before beginning the upgrade. The red repositories were not shown in the list of repositories on your system. Without those repositories, YaST will not find any of the packages it needs for the upgrade.

    Code:
    #  | Alias                                               | Name                                              | Enabled | Refresh
    ---+-----------------------------------------------------+---------------------------------------------------+---------+--------
    1  | ATI-Driver-SLE11-SP1                                | ATI-Driver-SLE11-SP1                              | Yes     | Yes    
    2  | ATI-Driver-SLE11-SP2                                | ATI-Driver-SLE11-SP2                              | Yes     | Yes    
    3  | Novell_NTS_-_Supportconfig                          | Novell NTS - Supportconfig                        | Yes     | Yes    
    4  | SUSE-Linux-Enterprise-Desktop-11-SP1_11.1.1-1.133_1 | SUSE-Linux-Enterprise-Desktop-11-SP1 11.1.1-1.133 | Yes     | Yes    
    5  | nVidia-Driver-SLE11-SP1                             | nVidia-Driver-SLE11-SP1                           | Yes     | Yes    
    6  | nVidia-Driver-SLE11-SP2                             | nVidia-Driver-SLE11-SP2                           | Yes     | Yes    
    7  | nu_novell_com:SLE11-SP1-Debuginfo-Pool              | SLE11-SP1-Debuginfo-Pool                          | No      | Yes    
    8  | nu_novell_com:SLE11-SP1-Debuginfo-Updates           | SLE11-SP1-Debuginfo-Updates                       | No      | Yes    
    9  | nu_novell_com:SLE11-SP2-Debuginfo-Core              | SLE11-SP2-Debuginfo-Core                          | No      | Yes    
    10 | nu_novell_com:SLE11-SP2-Debuginfo-Updates           | SLE11-SP2-Debuginfo-Updates                       | No      | Yes    
    11 | nu_novell_com:SLED11-Extras                         | SLED11-Extras                                     | No      | Yes    
    12 | nu_novell_com:SLED11-SP1-Pool                       | SLED11-SP1-Pool                                   | Yes     | Yes    
    13 | nu_novell_com:SLED11-SP1-Updates                    | SLED11-SP1-Updates                                | Yes     | Yes    
    14 | nu_novell_com:SLED11-SP2-Core                       | SLED11-SP2-Core                                   | Yes     | Yes    
    15 | nu_novell_com:SLED11-SP2-Updates                    | SLED11-SP2-Updates                                | Yes     | Yes
    I don't know why those two repositories are missing. You may find something in /var/log/YaST2/y2log.

    Where to go from here? Well you can try again following TID 7010200: How to upgrade to SLES/SLED 11 SP2.
    • Apply online updates.
    • Run wagon.
    • After the Customer Center configuration, but before continuing with the upgrade, check to see if the missing repositories are present:
    • Code:
      zypper lr
    • If they are, continue with the upgrade. If they are not you may have to upgrade from the DVD.


    If anyone else has any ideas, please feel free to jump in!
    Kevin Boyle - Knowledge Partner
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below this post. Thanks.

  9. #9

    Re: Failed to upgrade to SLED 11 SP2?

    Quote Originally Posted by KBOYLE View Post
    When you run "/usr/sbin/wagon &" it checks your registration and adds the required repositories to your system before beginning the upgrade. In the table below, the "bold" repositories (with "SP2") were added by wagon to my SLED11 system before beginning the upgrade. The red repositories were not shown in the list of repositories on your system. Without those repositories, YaST will not find any of the packages it needs for the upgrade.

    Code:
    #  | Alias                                               | Name                                              | Enabled | Refresh
    ---+-----------------------------------------------------+---------------------------------------------------+---------+--------
    1  | ATI-Driver-SLE11-SP1                                | ATI-Driver-SLE11-SP1                              | Yes     | Yes    
    2  | ATI-Driver-SLE11-SP2                                | ATI-Driver-SLE11-SP2                              | Yes     | Yes    
    3  | Novell_NTS_-_Supportconfig                          | Novell NTS - Supportconfig                        | Yes     | Yes    
    4  | SUSE-Linux-Enterprise-Desktop-11-SP1_11.1.1-1.133_1 | SUSE-Linux-Enterprise-Desktop-11-SP1 11.1.1-1.133 | Yes     | Yes    
    5  | nVidia-Driver-SLE11-SP1                             | nVidia-Driver-SLE11-SP1                           | Yes     | Yes    
    6  | nVidia-Driver-SLE11-SP2                             | nVidia-Driver-SLE11-SP2                           | Yes     | Yes    
    7  | nu_novell_com:SLE11-SP1-Debuginfo-Pool              | SLE11-SP1-Debuginfo-Pool                          | No      | Yes    
    8  | nu_novell_com:SLE11-SP1-Debuginfo-Updates           | SLE11-SP1-Debuginfo-Updates                       | No      | Yes    
    9  | nu_novell_com:SLE11-SP2-Debuginfo-Core              | SLE11-SP2-Debuginfo-Core                          | No      | Yes    
    10 | nu_novell_com:SLE11-SP2-Debuginfo-Updates           | SLE11-SP2-Debuginfo-Updates                       | No      | Yes    
    11 | nu_novell_com:SLED11-Extras                         | SLED11-Extras                                     | No      | Yes    
    12 | nu_novell_com:SLED11-SP1-Pool                       | SLED11-SP1-Pool                                   | Yes     | Yes    
    13 | nu_novell_com:SLED11-SP1-Updates                    | SLED11-SP1-Updates                                | Yes     | Yes    
    14 | nu_novell_com:SLED11-SP2-Core                       | SLED11-SP2-Core                                   | Yes     | Yes    
    15 | nu_novell_com:SLED11-SP2-Updates                    | SLED11-SP2-Updates                                | Yes     | Yes
    I don't know why those two repositories are missing. You may find something in /var/log/YaST2/y2log.

    Where to go from here? Well you can try again following TID 7010200: How to upgrade to SLES/SLED 11 SP2.
    • Apply online updates.
    • Run wagon.
    • After the Customer Center configuration, but before continuing with the upgrade, check to see if the missing repositories are present:
    • Code:
      zypper lr
    • If they are, continue with the upgrade. If they are not you may have to upgrade from the DVD.


    If anyone else has any ideas, please feel free to jump in!
    About the Online Update, I mentioned earlier that I cannot update two patches, maybe that's what's been causing the problem:

    Code:
    nothing provides hal = 0.5.12-23.58.22 needed by hal-devel-0.5.12-23.58.22.i586
    Options:
    
    • Following actions will be done: deinstallation of hal-devel-0.5.12-23.49.51.1.i586 deinstallation of gnome-vfs2-devel-2.24.2-2.6.1.i586 deinstallation of libgsf-devel-1.14.9-2.27.i586 deinstallation of librsvg-devel-2.26.0-2.3.1.i586
    • do not install patch: sdksp2-hal-6332.noarch
    • break hal-devel by ignoring some of its dependencies
    evolution-pilot-2.28.2-0.21.1.i586 requires evolution = 2.28.2-0.21.1, but this requirement cannot be provided) Options:
    • deinstallation of evolution-pilot-2.28.2-0.21.1.i586
    • do not install patch sdksp2-evolution-201207-6611.noarch
    • break evolution-pilot by ignoring some of its dependencies
    I'm really not sure what to do with them.

  10. #10

    Re: Failed to upgrade to SLED 11 SP2?

    Quote Originally Posted by PauliusC View Post
    About the Online Update, I mentioned earlier that I cannot update two patches, maybe that's what's been causing the problem:

    I'm really not sure what to do with them.
    Do you now have your missing repositories?

    In your previous post you show these repositories:
    • nu_novell_com:SLE11-SDK-SP2-Core
    • nu_novell_com:SLE11-SDK-SP2-Updates

    But you are missing these repositories:
    • nu_novell_com:SLED11-SP2-Core
    • nu_novell_com:SLED11-SP2-Updates


    Patch sdksp2-hal-6332.noarch is an SP2 patch but it can't find dependent packages probably because those SLED11-SP2 repositories are missing.

    It appears that wagon did not setup all the necessary repositories before beginning the upgrade. As I see it, you have a few choices:
    • You can attempt the upgrade using the DVD.
    • You can try to find out what went wrong with the wagon online upgrade:
      • If the missing repositories are created when you run wagon again, you may be able to complete the online upgrade.
      • If you are still unable to complete an online upgrade, you can open a Service Request for additional assistance. There may be a bug preventing the upgrade. Tech Support can help identify the issue and find a solution.


    Once you have installed all the SP2 packages, you should no longer have dependency issues with patches for the SDK.
    Kevin Boyle - Knowledge Partner
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below this post. Thanks.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •