Hello;

I am having an issue with Suse 11.2 and yum. It appears any repositories that are unsigned in a local repository are being deleted:


I have a repository pointed at the local folder /repo/kt-field, when I choose to install an unsigned rpm from there the rpm is deleted once yum runs. If I use the rpm tool to install the rpm it works fine.

t620:/repo/kt-field # pwd
/repo/kt-field
t620:/repo/kt-field # ls dlc102*
dlc102b-10.2-b1.x86_64.rpm
t620:/repo/kt-field # rpm --checksig dlc102b*
yudlc102b-10.2-b1.x86_64.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#0fd21d1d)
t620:/repo/kt-field # yum install dlc102b
Loaded plugins: priorities
4 packages excluded due to repository priority protections
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package dlc102b.x86_64 0:10.2-b1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ================================================== ================================================== ================================================== =======
Package Arch Version Repository Size
================================================== ================================================== ================================================== ================================================== =======
Installing:
dlc102b x86_64 10.2-b1 kt-field 117 M

Transaction Summary
================================================== ================================================== ================================================== ================================================== =======
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 117 M
Is this ok [y/N]: y
Downloading Packages:


Error Downloading Packages:
dlc102b-10.2-b1.x86_64: failure: dlc102b-10.2-b1.x86_64.rpm from kt-field: (256, 'No more mirrors to try.')

t620:/repo/kt-field # ls dlc102*
ls: cannot access dlc102*: No such file or directory
t620:/repo/kt-field # ls -altr
total 122160
-rwxr-xr-x 1 root 48 119420728 Nov 18 2009 dlc101c-10.1.c-1.x86_64.rpm
-rwxr-xr-x 1 root 48 15000 Apr 7 2011 perl-Locale-PO-0.21-1.el5.rf.noarch.rpm
-rwxr-xr-x 1 root 48 406405 Apr 7 2011 pcre-devel-8.02-1.jason.1.x86_64.rpm
-rwxr-xr-x 1 root 48 512959 Apr 7 2011 pcre-8.02-1.jason.1.x86_64.rpm
-rwxr-xr-x 1 root 48 36158 Jul 4 09:15 dbautil-1.0-19.x86_64.rpm
-rwxr-xr-x 1 root 48 36278 Jul 6 09:00 dbautil-1.0-18.x86_64.rpm
-rwxr-xr-x 1 root 48 36280 Jul 6 09:00 dbautil-1.0-17.x86_64.rpm
-rwxr-xr-x 1 root 48 36259 Jul 8 06:16 dbautil-1.0-20.x86_64.rpm
-rwxr-xr-x 1 root 48 2199672 Jul 13 10:48 appdoccode-20-2.x86_64.rpm
-rwxr-xr-x 1 root 48 2203504 Aug 21 15:43 appdoccode-20-3.x86_64.rpm
drwxr-xr-x 3 root 48 16384 Aug 21 15:43 cache
drwxr-xr-x 2 root 48 4096 Sep 13 12:36 repodata
-rwxr-xr-x 1 root 48 112 Sep 13 12:36 config.repo
drwxr-xr-x 4 root root 4096 Sep 19 15:04 ..
drwxr-xr-x 4 root 48 4096 Sep 19 16:26 .


Any ideas whats going on? I have a suse 11.1 box and the repository is working fine. Checked the yum.conf on both and there are no major differences.