Date of purchasing: 22 aug 2011
Purchased without extended waranty, just with 90 days trial updates for
SuSE
(will expired at 22 nov 2011)

No recovery DVD and no any registration code from HP shipped with this
notebook,
just the recovery partition on internal HDD.


I'm trying both without success:

activating Novell Customer's Center after full system recover and

- Yast -> Novell Customer Center Configuration:

All switches in its default state:

> [x] Hardware Profile
> [x] Optional Information
> [ ] Registration Code
> [x] Regularly Synchronize with the Customer Center
>

After pressing [Next] button some dialogs showed (without action
requires) and
following message box at end:

> (from superuser)
> Software repositories did not neet to be changed.
> [OK]
>



Actual result:
No online repositories connected, only SLED11 local hard drive and
drivers online repositories:


Code:
--------------------
$ zypper lr -d | awk '-F|' '{print $8 }'
URI

http://www2.ati.com/suse/hp/cnb/sle11sp1
http://www.broadcom.com/docs/linux_s...P/bnb/sle11sp1
https://nu.novell.com/repo/$RCE/SLED11-SP1-HP-CNB-Unregistered-Updates/sle-11-i586/
hd:///sled11.00?device=/dev/sda1&filesystem=auto
hd:///maintenance-updates?device=/dev/sda1
http://download.nvidia.com/novell/sle11sp1

--------------------



Expected result:
SLED11-SP1-Pool and SLED11-SP1-Updates repositories will appears into
zypper lr output.
Also I expect SDK will appears in available product (currently list is
empty).


Details:


Into /root/.suse_register.log after configuration NCC at Yast appears
following:

> .....
> 2011-10-26 23:30:14 SUSE::SRPrivate - [info] SEND DATA to URI:
> https://secure-www.novell.com/center...S&version=1.0:
> .....
> <?xml version="1.0" encoding="UTF-8"?>
> <productlist xmlns="http://www.novell.com/xml/center/regsvc-1_0"
> lang="en">
> <product>ATI Video Drivers</product>
> ...
> <product>SUSE-Linux-Enterprise-Desktop-SP1</product>
> <product>SUSE-Linux-Enterprise-Desktop-SP1-migration</product>
> <product>SUSE-Linux-Enterprise-Desktop-SP2</product>
> <product>SUSE-Linux-Enterprise-Desktop-SP2-migration</product>
> <product>SUSE-Linux-Enterprise-Desktop-SP3</product>
> <product>SUSE-Linux-Enterprise-Desktop-SP3-migration</product>
> <product>SUSE-Linux-Enterprise-Desktop-SP4</product>
> ...
> <product>SUSE-Linux-Enterprise-SDK-SP1</product>
> <product>SUSE-Linux-Enterprise-SDK-SP1-migration</product>
> <product>SUSE-Linux-Enterprise-SDK-SP2</product>
> <product>SUSE-Linux-Enterprise-SDK-SP2-migration</product>
> <product>SUSE-Linux-Enterprise-SDK-SP3</product>
> <product>SUSE-Linux-Enterprise-SDK-SP3-migration</product>
> <product>SUSE-Linux-Enterprise-SDK-SP4</product>
> ...
> <product>SUSE_SLED</product>
> <product>SUSE_SLED-SP1-migration</product>
> <product>SUSE_SLED-SP2-migration</product>
> <product>SUSE_SLES</product>
> <product>SUSE_SLES-SP1-migration</product>
> <product>SUSE_SLES-SP2-migration</product>
> ...
>
>
>
> 2011-10-26 23:30:15 SUSE::SRPrivate - [info] SEND DATA to URI:
> https://secure-www.novell.com/center...S&version=1.0:
> 2011-10-26 23:30:15 SUSE::SRPrivate - [info] <?xml version="1.0"
> encoding="utf-8"?>
> <register xmlns="http://www.novell.com/xml/center/regsvc-1_0"
> accept="optional" client_version="1.4.0">
> <guid>5e95d5*****************3443fcd4</guid>
> <host />
> <product version="11.1" release="HP-CNB"
> arch="i586">SUSE_SLED</product>
> <param id="timezone">Asia/Novosibirsk</param>
> <param id="processor">athlon</param>
> <param id="platform">i386</param>
> </register>
> 2011-10-26 23:30:16 SUSE::SRPrivate - [info] CODE: 302 MESSAGE: Moved
> Temporarily
> ...
> 2011-10-26 23:30:16 SUSE::SRPrivate - [info] SEND DATA to URI:
> https://secure-www.novell.com/center...S&version=1.0:
> 2011-10-26 23:30:16 SUSE::SRPrivate - [info] <?xml version="1.0"
> encoding="utf-8"?>
> <register xmlns="http://www.novell.com/xml/center/regsvc-1_0"
> accept="optional" client_version="1.4.0">
> <guid>5e95d5*****************3443fcd4</guid>
> <host />
> <product version="11.1" release="HP-CNB"
> arch="i586">SUSE_SLED</product>
> <param id="timezone">Asia/Novosibirsk</param>
> <param id="processor">athlon</param>
> <param id="platform">i386</param>
> </register>
> 2011-10-26 23:30:18 SUSE::SRPrivate - [info] CODE: 200 MESSAGE: OK
> 2011-10-26 23:30:18 SUSE::SRPrivate - [info] Date: Tue, 25 Oct 2011
> 16:30:36 GMT
> 2011-10-26 23:30:18 SUSE::SRPrivate - [info] Content-Type:
> text/xml;charset=UTF-8
> 2011-10-26 23:30:18 SUSE::SRPrivate - [info] Content-Length: 752
> 2011-10-26 23:30:18 SUSE::SRPrivate - [info] Set-Cookie:
> ZNPCQ002-center=V0016cd87b2f; path=/
> 2011-10-26 23:30:18 SUSE::SRPrivate - [info] P3p: CP="NOI"
> 2011-10-26 23:30:18 SUSE::SRPrivate - [info] Via: 1.1 ICS_SERVER
> (iChain 2.3.419)
> 2011-10-26 23:30:18 SUSE::SRPrivate - [info]
> 2011-10-26 23:30:18 SUSE::SRPrivate - [info]
> 2011-10-26 23:30:18 SUSE::SRPrivate - [info] <?xml version="1.0"
> encoding="UTF-8"?>
> <needinfo xmlns="http://www.novell.com/xml/center/regsvc-1_0"
> href="https://secure-www.novell.com/center/regsvc-1.0/?command=interactive&amp;lang=en&amp;guid=5e95d5** ****************3443fcd4"
> lang="en">
> <param description="Hardware inventory" id="hw_inventory">
> <param command="hwinfo --gfxcard" description="Graphics card details"
> id="gfxcard"></param>
> <param command="hwinfo --netcard --nowpa" description="Network card
> data" id="netcard"></param>
> <param command="hwinfo --modem" description=""
> id="modem"></param></param>
> <privacy class="informative" description="Submit information to help
> you manage your registered systems."
> url="http://www.novell.com/company/policies/privacy/textonly.html">
> </privacy>
> </needinfo>
> 2011-10-26 23:30:22 SUSE::SRPrivate - [info] SEND DATA to URI:
> https://secure-www.novell.com/center...S&version=1.0:
> 2011-10-26 23:30:22 SUSE::SRPrivate - [info] <?xml version="1.0"
> encoding="utf-8"?><register
> xmlns="http://www.novell.com/xml/center/regsvc-1_0" accept="mandatory"
> client_version="1.4.0"><guid>5e95d**************** ***3443fcd4</guid><host
> />
> <product version="11.1" release="HP-CNB"
> arch="i586">SUSE_SLED</product>
> <param id="netcard">
> <![CDATA[34: PCI 600.0: 0200 Ethernet controller
> 2011-10-26 23:30:22 SUSE::SRPrivate - [info] [Created at pci.318]
> 2011-10-26 23:30:22 SUSE::SRPrivate - [info] UDI:
> /org/freedesktop/Hal/devices/pci_10ec_8136
> .........
> 2011-10-26 23:30:22 SUSE::SRPrivate - [info] Primary display adapter:
> #9]]></param></register>
> 2011-10-26 23:30:24 SUSE::SRPrivate - [info] CODE: 302 MESSAGE: Moved
> Temporarily
>
> ...
> 2011-10-26 23:30:24 SUSE::SRPrivate - [info] SEND DATA to URI:
> https://secure-www.novell.com/center...S&version=1.0:
> 2011-10-26 23:30:24 SUSE::SRPrivate - [info] <?xml version="1.0"
> encoding="utf-8"?>
> <register xmlns="http://www.novell.com/xml/center/regsvc-1_0"
> accept="mandatory"
> client_version="1.4.0"><guid>5e95d5*************** ****3443fcd4</guid><host
> />
> <product version="11.1" release="HP-CNB"
> arch="i586">SUSE_SLED</product>
> <param id="netcard"><![CDATA[34: PCI 600.0: 0200 Ethernet controller
> 2011-10-26 23:30:24 SUSE::SRPrivate - [info] [Created at pci.318]
> 2011-10-26 23:30:24 SUSE::SRPrivate - [info] UDI:
> /org/freedesktop/Hal/devices/pci_10ec_8136
> 2011-10-26 23:30:24 SUSE::SRPrivate - [info] Unique ID:
> rBUF.chVMbTiB80C
> ....
> 2011-10-26 23:30:24 SUSE::SRPrivate - [info] Primary display adapter:
> #9]]></param></register>
> 2011-10-26 23:30:28 SUSE::SRPrivate - [info] CODE: 200 MESSAGE: OK
>
> 2011-10-26 23:30:28 SUSE::SRPrivate - [info] RECEIVED DATA:
> ...
> 2011-10-26 23:30:28 SUSE::SRPrivate - [info] <?xml version="1.0"
> encoding="UTF-8"?>
> <zmdconfig xmlns="http://www.novell.com/xml/center/regsvc-1_0"
> lang="en">
> <guid>5e95d5***********************3443fcd4</guid>
> <service id="www_broadcom_com_hp_bnb_sle11_sp1" type="zypp"
> description="Broadcom HP BNB Network Driver for SLE11 SP1">
> <param
> id="url">http://www.broadcom.com/docs/linux_sta/repo/HP/bnb/sle11sp1</param>
> <param name="catalog">Broadcom-Driver-HP-BNB-SLE11-SP1</param>
> </service>
> <service id="download_nvidia_com_sle11_sp1" type="zypp"
> description="nVidia Video Drivers for SLE11">
> <param id="url">http://download.nvidia.com/novell/sle11sp1</param>
> <param name="catalog">nVidia-Driver-SLE11-SP1</param>
> </service>
> <service id="www2_ati_com_suse_hp_cnb_sle11_sp1" type="zypp"
> description="ATI Driver for HP CNB SLE11 SP1">
> <param id="url">http://www2.ati.com/suse/hp/cnb/sle11sp1</param>
> <param name="catalog">ATI-Driver-HP-CNB-SLE11-SP1</param>
> </service>
> <status generated="1319560246">
> <productstatus product="SUSE_SLED" version="11.1" release="HP-CNB"
> arch="i586" result="success" errorcode="OK">
> <!-- my comment here:
> $ date -d @1413222825
> Tue Oct 14 00:53:45 NOVST 2014Tue Oct 14 00:53:45 NOVST 2014
> end of my comment -->
> <subscription status="ACTIVE" expiration="1413222825" type="FULL"/>
> <message>No errors.</message>
> </productstatus>
> <productstatus product="LSI HP BNB Modem Driver for SLE11 SP1"
> version="" release="" arch="" result="success" errorcode="OK">
> <message>No errors.</message>
> </productstatus>
> <productstatus product="Broadcom HP BNB Network Driver for SLE11 SP1"
> version="" release="" arch="" result="success" errorcode="OK">
> <message>No errors.</message>
> </productstatus>
> <productstatus product="nVidia Video Drivers for SLE 11 SP1"
> version="" release="" arch="" result="success" errorcode="OK">
> <message>No errors.</message>
> </productstatus>
> <productstatus product="ATI HP CNB Driver for SLE11 SP1" version=""
> release="" arch="" result="success" errorcode="OK">
> <message>No errors.</message>
> </productstatus>
> </status>
> </zmdconfig>
>


On this .suse_register.log is finished, none added after click [OK]
button at final dialog, described early.




EXTRA DETAILS:

I have read other thread-
http://forums.novell.com/suse/suse-p...-11-oem-2.html

Here wroten:

> There is a team at HP that works closely with SUSE. Bugs are sometimes
> hard to replicate.
>

so I can provide lot of details here at hope this can help us to
localize and fix this very anoying bug. It's not hard to me to replicate
this bug



Code:
--------------------
> cat /etc/ImageVersion

14.2.0

--------------------




Code:
--------------------
> uname -r

2.6.32.29-0.3-pae

--------------------




Code:
--------------------
> zypper list-updates

Loading repository data...
Reading installed packages...
No updates found.

--------------------



Code:
--------------------
> sudo suse_register --restore-repos

Registration finished successfully

--------------------
(after this output of `zypper lr` remains unchanged, only 6 listed above
repositories).


Code:
--------------------
> LANG=C sudo zypper refresh --services

All services have been refreshed.
Repository 'ATI-Driver-HP-CNB-SLE11-SP1' is up to date.
Repository 'Broadcom-Driver-HP-BNB-SLE11-SP1' is up to date.
Repository 'HP-SBSO-Emergency-Channel' is up to date.
Repository 'SUSE-Linux-Enterprise-Desktop-11-SP1 11.1.1-1.133' is up to date.
Retrieving repository 'SuSE-Linux-Maintenance-Updates' metadata [done]
Repository 'nVidia-Driver-SLE11-SP1' is up to date.
All repositories have been refreshed.

--------------------


(this is same 6 repositories- online drivers and local SLED from
recovery partition).


If need some another details, tests, etc- feel free to ask here or via
PM.


--
asashnov
------------------------------------------------------------------------
asashnov's Profile: http://forums.novell.com/member.php?userid=118494
View this thread: http://forums.novell.com/showthread.php?t=447318