Results 1 to 3 of 3

Thread: Trying to upgrade guest VM

  1. #1

    Trying to upgrade guest VM

    I have a VM guest running Sles 10 Sp3 on Sles 11 sp1 host. I have added a cdrom mapping in the cofig for the guest to the Sles sp1 iso image. However when I boot the guest it will not boot from the iso. I exported out the config information and changed the bootable flag from 0 to 1. I then imported the config back in. When I go to boot the VM I receive the following error, "xend.err "bootloader did not return any data". If I remove the iso mapping the VM boots fine. However I need to boot from the iso in order to upgrade the OS. Any ideas?

  2. Re: Trying to upgrade guest VM

    Hi
    Did you check the iso image md5sum?

    Have you also read this document; https://www.suse.com/support/kb/doc.php?id=7010200
    "There is no supported direct migration path to SLES/SLED 11 SP2. An update has to be performed from SLES/SLED 10 GA to SP 1, then to SP 2, further to SP 3, and then to SP4 by using the respective boot media."
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. Re: Trying to upgrade guest VM

    Here's how I have done vm upgrades:
    Shutdown old vm.

    On virt-manager create new vm (like vm-upgrade) with option "yes I need
    to install operating system'. For disk config point to existing disk
    image/partition. For installation media point to iso/cdrom.

    After installation/upgrade shutdown vm-upgade and start old vm.

    If having any issues compare vm vm-upgrade config files.

    Take backups before you start if you want to be sure.

    On 11.10.2012 21:14, krobertsjr wrote:
    >
    > I have a VM guest running Sles 10 Sp3 on Sles 11 sp1 host. I have added
    > a cdrom mapping in the cofig for the guest to the Sles sp1 iso image.
    > However when I boot the guest it will not boot from the iso. I exported
    > out the config information and changed the bootable flag from 0 to 1. I
    > then imported the config back in. When I go to boot the VM I receive the
    > following error, "xend.err "bootloader did not return any data". If I
    > remove the iso mapping the VM boots fine. However I need to boot from
    > the iso in order to upgrade the OS. Any ideas?
    >
    >



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •