I just got hit by some issues when installing sles to iscsi LUN.

Main issue is that sle sp2 driver does not support latest emulex
firmware (4.1.402).

here's how I managed to install sles11 SP2:

1. Start sles install with withiscsi=1
2. Configure Emulex be2net port with storage network ip
3. On iscsi target configuration, remove offloaded connections and add
software ones.
4. On first boot, you have to prevent be2iscsi loading. I edited grub
command line and added invalid module parameter be2iscsi.blacklist=1.
This prevent be2module from loading and I can finalize installation.
5. On running system, compile and install newest drivers from HP. Driver
installation will create new initrd images with newer drivers and system
will boot fine.

And notice also that:
Hp iSCSI drivers does not support libiscsi, so all emulex connections
have to be managed with emulex ocmanager.