Hi All,


We are using SLES10.3 Linux virtual servers (vmware) & the servers does not have GUI mode & gnome packages were not installed. For a requirement, we have installed gnome package+x11 interface using yast. Installation was successful but unable to start the gui mode & getting error as Xserver crashed. Please provide your feedback to correct the issue.

OS: SLES 10.3 X86-64

from /var/log/messages:

Nov 8 03:04:51 SUSE103 gdm[3536]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
Nov 8 03:04:56 SUSE103 gdm[3546]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
Nov 8 03:04:56 SUSE103 gdm[3265]: deal_with_x_crashes: Running the XKeepsCrashing script
Nov 8 03:08:01 SUSE103 gdm[3265]: Failed to start X server several times in a short time period; disabling display :0
----------------------------------------------------------------------------------------------------------------------------------

when it was started manually by startx command, getting the below messages.

SUSE103:~ # startx
xauth: creating new authority file /root/.serverauth.3744


X Window System Version 6.9.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 6.9
Build Operating System: SuSE Linux [ELF] SuSE
Current Operating System: Linux SUSE103 2.6.16.60-0.54.5-default #1 Fri Sep 4 01:28:03 UTC 2009 x86_64
Build Date: 05 September 2009
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov 8 03:26:38 2012
(EE) Unable to locate/open config file
xf86AutoConfig: Primary PCI is 0:15:0
Running "/usr/X11R6/bin/getconfig -X 60900000 -I /etc/X11,/usr/X11R6/etc/X11,/usr/X11R6/lib64/modules/updates,/usr/X11R6/lib64/modules,/usr/X11R6/lib/X11/getconfig -v 0x15ad -d 0x0405 -r 0x00 -s 0x15ad -b 0x0405 -c 0x0300"
getconfig.pl: Version 1.0.
getconfig.pl: Xorg Version: 6.9.0.0.
getconfig.pl: 23 built-in rules.
getconfig.pl: rules file '/usr/X11R6/lib/X11/getconfig/xorg.cfg' has version 1.0.
getconfig.pl: 1 rule added from file '/usr/X11R6/lib/X11/getconfig/xorg.cfg'.
getconfig.pl: Evaluated 24 rules with 0 errors.
getconfig.pl: Weight of result is 500.
New driver is "vmware"
(==) Using default built-in configuration (53 lines)
ACPI: OSPMOpen called
ACPI: Opening device

Fatal server error:
Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices


Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

ACPI: Closing device
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0
----------------------------------------------------------------------------------------------------------------------------------