Upgrading from SLES10 to SLES11 SP1 + HAE with conversion tool
/usr/lib64/heartbeat/hb2openais.sh worked without problems. I got no
errors converting cib.xml.
But starting the cluster I get the following error:
Sep 07 17:25:44 corosync [MAIN ] Corosync Cluster Engine ('1.3.0'):
started and ready to provide service.
Sep 07 17:25:44 corosync [MAIN ] Corosync built-in features: nss
Sep 07 17:25:44 corosync [MAIN ] Successfully configured openais
services to load
Sep 07 17:25:44 corosync [MAIN ] Successfully read main configuration
file '/etc/corosync/corosync.conf'.
Sep 07 17:25:44 corosync [MAIN ] parse error in config: The token hold
timeout parameter (29 ms) may not be less then (30 ms).
Sep 07 17:25:44 corosync [MAIN ] Corosync Cluster Engine exiting with
status 8 at main.c:1675.

Where can I find this parameter?

My corosync.conf:
# Generated by hb2openais on Wed Sep 7 15:48:11 CEST 2011
# Please read the corosync.conf.5 manual page
compatibility: whitetank
aisexec {
# Run as root - this is necessary to be able to manage
resources with Pacemaker
user: root
group: root
}
service {
# Load the Pacemaker Cluster Resource Manager
name: pacemaker
ver: 0
}
totem {
version: 2
# How long before declaring a token lost (ms)
token: 1000
# How many token retransmits before forming a new configuration
token_retransmits_before_loss_const: 20
# How long to wait for join messages in the membership protocol
(ms)
join: 50
# How long to wait for consensus to be achieved before
# starting a new round of membership configuration (ms)
consensus: 1200
# Turn off the virtual synchrony filter
vsftype: none
# Number of messages that may be sent by one processor on
receipt of the token
max_messages: 20
# Limit generated nodeids to 31-bits (positive signed integers)
clear_node_high_bit: yes
# Enable encryption
secauth: on
threads: 4
# Optionally assign a fixed node id (integer)
# nodeid: 1234
interface {
ringnumber: 0
bindnetaddr: 192.168.100.0
mcastport: 5406
mcastaddr: 226.94.1.1
}
}
logging {
debug: off
fileline: off
to_stderr: no
timestamp: on
to_logfile: yes
logfile: /var/log/ha-log
to_syslog: yes
syslog_facility: daemon
logger_subsys {
subsys: AMF
debug: off
}
}
amf {
mode: disabled
}

Thanks for any suggestions
Thomas


--
vsaadmin
------------------------------------------------------------------------
vsaadmin's Profile: http://forums.novell.com/member.php?userid=54712
View this thread: http://forums.novell.com/showthread.php?t=444385