Results 1 to 3 of 3

Thread: Get rstatd to bind to a specific port

  1. #1

    Get rstatd to bind to a specific port

    Hi,
    We are running SLESz 11.2. I want to use rstatd for server monitoring. Rstatd runs under inetd, and if I cat the /etc/xinet.d/rstatd file, I get the following:
    Code:
    service rstatd
    {
            type                    = RPC
            rpc_version             = 2
            flags                   = IPv4
            socket_type             = dgram
            protocol                = udp
            wait                    = yes
            user                    = root
            group                   = root
            server                  = /usr/sbin/rpc.rstatd
            disable                 = yes
    }
    There is no port specification in this file, and I believe that even if you specify a port entry, the xinetd will ignore it.

    One can therefore only configure the firewall everytime that the port changes, run without firewall or not use rstatd at all.

    Are there any solutions for this ?

    TIA

  2. #2
    Automatic reply NNTP User

    Re: Get rstatd to bind to a specific port

    ou,

    It appears that in the past few days you have not received a response to your
    posting. That concerns us, and has triggered this automated reply.

    Has your issue been resolved? If not, you might try one of the following options:

    - Visit http://www.suse.com/support and search the knowledgebase and/or check all
    the other support options available.
    - You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (http://forums.suse.com)

    Be sure to read the forum FAQ about what to expect in the way of responses:
    http://forums.suse.com/faq.php

    If this is a reply to a duplicate posting, please ignore and accept our apologies
    and rest assured we will issue a stern reprimand to our posting bot.

    Good luck!

    Your SUSE Forums Team
    http://forums.suse.com



  3. #3
    Join Date
    Mar 2013
    Location
    Seattle, WA
    Posts
    20

    Re: Get rstatd to bind to a specific port

    It works for us.

    1. create /etc/xinetd.d/rstatd-server with contents
    service rstatd
    {
    disable = no
    type = RPC
    socket_type = dgram
    protocol = udp
    server = /usr/sbin/rpc.rstatd
    wait = yes
    flags = IPv4
    port = 60222
    user = root
    group = root
    rpc_version = 1-4
    instances = 1
    }

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •