Results 1 to 3 of 3

Thread: update a para-virtualization VM to full-virtualization VM.

  1. #1

    Question update a para-virtualization VM to full-virtualization VM.

    Hi.
    I use suse linux 11 SP2 + Xen4.1 + HA to create a para-virtualisation VM. VM OS is suse linux SP2. the kenel is vmlinuz-3.0.13-0.27-xen. then i change this VM from para-virtualisation VM to full-virtualization VM. I do below steps.

    1) install a new kernel with the suse linux SP2 CD by YST. new kernel is vmlinuz-3.0.13-0.27-default. /boot/grub/menu.lst is update accordingly.
    2)chage the /etc/fstab file. update all fields with xvda to hda. same thing for the xvdb ...
    3)in Dom0. change the VM startup config files. from
    builder="linux"
    bootloader="/usr/bin/pygrub"
    bootargs=""
    extra=""

    to
    builder="hvm"
    device_model="/usr/lib/xen/bin/qemu-dm"
    kernel="/usr/lib/xen/boot/hvmloader"

    also change all xvdN to hdN.

    then startup the vm using xm create <vmconfigfile>.

    VM startup successfully. I check the kernel is changed to vmlinuz-3.0.13-0.27-default.

    is this method correct? did i missed something?
    is there any potential issues to running the legacy software already installed?

    Thanks.

    Jing Chen

  2. #2
    David Gersic NNTP User

    Re: update a para-virtualization VM to full-virtualization VM.

    On Thu, 29 Nov 2012 10:04:02 +0000, echejin wrote:

    > is this method correct? did i missed something? is there any potential
    > issues to running the legacy software already installed?


    Are you having a problem? How does this relate to the High Availability
    Extension?


    --
    --------------------------------------------------------------------------
    David Gersic dgersic_@_niu.edu
    Knowledge Partner http://forums.netiq.com

    Please post questions in the forums. No support provided via email.


  3. #3

    Re: update a para-virtualization VM to full-virtualization V

    Quote Originally Posted by David Gersic View Post
    On Thu, 29 Nov 2012 10:04:02 +0000, echejin wrote:

    > is this method correct? did i missed something? is there any potential
    > issues to running the legacy software already installed?


    Are you having a problem? How does this relate to the High Availability



    --
    --------------------------------------------------------------------------
    David Gersic dgersic_@_niu.edu
    Knowledge Partner http://forums.netiq.com

    Please post questions in the forums. No support provided via email.
    '

    I am doing regression test and i just want to know from the expert viewpoint if there is potential
    problem. we use the suse HA extension for the HA. i create two VMs for HA backup and they are para-visualisation.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •