My software stack is planning on moving to gcc 4.7.2 to take advantage of new C++ features and performance improvements.
Unfortunately much of our internal infrastructure is running SLES 10 SP4 and a lot of the dependencies(gmp, mpc, mpfr) needed to compile gcc 4.7.2 appear to be incompatible(Novel doesn't provide binaries for 4.7.2).
Is there any plan to support newer versions of gcc on SLES 10 SP4?
I believe general support for SLES 10 SP4 ends July 2013, so I'm guessing the answer is no.
If that is the case is my only option to upgrade to SLES 11?
Thanks.